Results 1 to 7 of 7

Thread: YAST: Unable to create repository?

  1. #1

    Default YAST: Unable to create repository?

    Why does this happen? I am (this time) trying to install Atmel's gnu-avr toolchain. Atmel's web site gives the repository as http:www.atmel.no/avr32/suse/11.0/i586. I put that into YAST2's repository manager, and it comes back with "unable to create repository from URL..."

    Why does this happen? It's hardly unique to the Atmel repository: in fact, it seems to be YAST's default behavior on ANYTHING other than the official SUSE repos.

    Is there some way to fix this, or bypass it with some other installation tool, so I can get the software I need?

    Thanks,
    James
    Last edited by jamesqf; 12-Jan-2010 at 15:43. Reason: Mistyped URL

  2. #2
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: YAST: Unable to create repository?

    Enter the url without the i586. Generally this applies to all repos added to YaST.

  3. #3

    Default Re: YAST: Unable to create repository?

    Thanks. Looks like it worked: at least it found & downloaded a newer version of avr-gcc. Now to see if it's new enough...

    I would have sworn that I had tried setting the repository name without the i586, because I looked at the link and found files at the URL without it.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: YAST: Unable to create repository?

    You can certainly go there by browser but the repository path must lead to the repository configuration/definition files.

  5. #5

    Default Re: YAST: Unable to create repository?

    I'm having the same problem with a different. I'm new to linux/opensuse and i'm trying to get my wifi to work by installing the drivers/firmware. I'm trying to follow this guide: BCM43224, BCM43225 and BCM4313 installation guide but when I try to enter the web address to yast I get the error that it is unable to create the repository. I tried:

    git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git
    git.kernel.org - linux/kernel/git/dwmw2/linux-firmware.git/summary and
    https://git.kernel.org/?p=linux/kern...x-firmware.git

    with no luck. Can anyone help point me in the right direction as to what im doing wrong and what i need to do to install these drivers/firmware?
    if im missing any needed info please let me know, im still trying to figure things out. Ive already tried searching for hours before this with no luck.

    Thanks

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: YAST: Unable to create repository?

    On 2011-05-05 08:36, mkkuntz8 wrote:
    > I'm having the same problem with a different. I'm new to linux/opensuse
    > and i'm trying to get my wifi to work by installing the


    I think you should be asking in the wireless subforum.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: YAST: Unable to create repository?

    On 05/05/2011 11:20 AM, Carlos E. R. wrote:
    >
    > I think you should be asking in the wireless subforum.


    after going through the three stickies at the top of that forum..

    --
    CAVEAT: http://is.gd/bpoMD
    [openSUSE11.3 + KDE4.5.5 + Firefox3.6.17 + Thunderbird3.1.10 via NNTP]
    HACK Everything -> http://www.youtube.com/watch?v=j5b4CCe9pS8&NR=1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •