Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Connect to internet through company network

  1. #1

    Default Connect to internet through company network

    Hello,

    I freshly installed opensuse Gnome 11.2 version and having troubles connecting to internet. I have dual boot on my computer - MS Windows XP and OpenSuse Gnome. No problem connecting to internet from the windows version.

    I believe the part of the problem connecting to internet from the open suse is because my computer is within company network.

    The ip address is: 10.158.3.86
    default gateway is : 10.158.1.111
    DHCP: 10.158.1.50
    DNS: 10.190.1.50

    I have already ran the network manager and input all information that was need but without luck.
    What would be a standard procedure to set up network under above mentioned circumstances?

    I appreciate your response.

    Lubica

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Connect to internet through company network

    Who gave you these addresses?
    Did you enter the correct subnet mask?

    Also, how come, you got a DHCP address?
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3

    Default Re: Connect to internet through company network

    Hi,

    Thanks for reply. The addresses I got from the command console and by typing ipconfig/all. It gave me everything I need.

    Subnet mask is 255.255.0.0. I reentered information couple times and even reinstal opensuse couple times. I also tried to set up the network during the installation process but it does not work.

    Again, I believe setup needs to be different once the computer is within private (company) network. But don't know how to set it up.

    Again, I will appreciate any information to get it running. Thnak you.

  4. #4
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Connect to internet through company network

    If the address was obtained automatically by DHCP in Windows, you can do the same thing in Linux too. You don't have to feed in all those details there. Just use it to use DHCP settings.
    Once that is done, go to a terminal and see if it has really obtained the IP address and routing information.
    Code:
    /sbin/ifconfig
    /sbin/route
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  5. #5

    Default Re: Connect to internet through company network

    Hi,

    Well thanks so much for your response. I really appreciate it.

    Anyway, now I have a little icon that says 'Wired network connection 'Autho eth 0 active'but when I open my mozilla and type something like google.com, at first it shows 'looking up google.com', then 'connecting...' but it never connects to it.

    What else needs to be configured for it to run??

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Connect to internet through company network

    Probably you need to set your web browser to use the company web proxy. Many enterprises don't allow direct surfing, but require you to go through a proxy. You could try to autodetect the proxy setting, for Firefox: Edit > Preferences > Advanced > Network > Connection > Autodetect proxy. If that doesn't work you'll have to ask your sysadmin what the URL of the company proxy is and fill it in.

  7. #7

    Default Re: Connect to internet through company network

    Ken_Yap,

    Thanks so much!!! I used our company proxy and it works. Hehehe...happy person right now.

    Lubica

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Connect to internet through company network

    Excellent. Enjoy Linux.

  9. #9

    Default Re: Connect to internet through company network

    Keeping on the same concept, I have a question/problem that goes to the step beyond getting the browser working. During the installation of 11.2 we added the system to our Windows domain and I can browse all the machines in the network, etc. I can even connect to our VPN from home wiht this notebook (yay!). We use an ISA server for our VPN and for our outbound proxy. I cannot for the life of me get the system to go through it for things like updates, etc. I've tried with both the Yast Proxy configuration tool as well as the "Control Center" Network Proxy without success. The ISA server claims that it's not being passed credentials although I'm hard-coding them (although I'd rather not have to).

    Thanks!
    John

  10. #10

    Default Re: Connect to internet through company network

    Hi John,

    I have exactly same problem as you and often getting 'ERROR 407 proxy authentication required'. Meantime the proxy settings (from Yast) are tested successfully, can connect to opensuse updates via Firefox but can't run 'online update' through Yast. I have a feeling the whole thing needs to bypass company security and proxy settings but have not clue how.

    I just randomly came across 'cntlm' that supposed to take all proxy into your hands and currently testing it for Windows but it is another headache to figure out how to properly configure the whole thing. Will keep you posted and vice versa let me know if find out something.

    Thanks,

    Lubica

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •