Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: remove default kernel?

  1. #1

    Default remove default kernel?

    On Saturday I ran online update, which included a kernel update (now 2.6.31.8-0.1.1 x86_64). Afterwards, I set out to recompile the VMWare module, as is always required, but it complained about not finding the kernel headers for the "desktop" kernel. I have not paid a great deal of attention to the kernel since installing 11.2, but I had assumed that I was running the "default" kernel. Maybe not.

    Anyway, at some point I installed the default kernel in an attempt to solve the kernel header problem, and not I have both the default and desktop kernels installed. I am booting to the desktop kernel.

    I only want the desktop kernel installed, but if I tried to remove the default kernel through yast it insists on installing the "default-base" package, whatever that is. I'm confused about that, as there is also a "desktop-base" package.

    Anyway, what packages do I need installed to run with the desktop kernel (only)?

    After solving that, I'll be putting up a thread about the VMWare Workstation issue. Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: remove default kernel?

    Open a terminal and post result of this

    Code:
    rpm --query --all '*kernel*'
    and
    Code:
    uname -a
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: remove default kernel?

    Here ya go!

    Code:
    rpm --query --all '*kernel*'
    kernel-default-2.6.31.8-0.1.1.x86_64
    patterns-openSUSE-devel_kernel-11.2-20.22.1.x86_64
    kernel-default-devel-2.6.31.8-0.1.1.x86_64
    kernel-desktop-devel-2.6.31.8-0.1.1.x86_64
    kernel-firmware-20090821-4.1.noarch
    kernel-desktop-2.6.31.8-0.1.1.x86_64
    nfs-kernel-server-1.1.3-21.3.1.x86_64
    linux-kernel-headers-2.6.31-3.4.noarch
    kernel-syms-2.6.31.8-0.1.1.x86_64
    kernel-xen-devel-2.6.31.8-0.1.1.x86_64
    kernel-debug-devel-2.6.31.8-0.1.1.x86_64
    kernel-source-2.6.31.8-0.1.1.noarch
    Code:
    uname -a
    Linux linux-7jrk 2.6.31.8-0.1-desktop #1 SMP PREEMPT 2009-12-15 23:55:40 +0100 x86_64 x86_64 x86_64 GNU/Linux

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: remove default kernel?

    kernel-default-2.6.31.8-0.1.1.x86_64
    patterns-openSUSE-devel_kernel-11.2-20.22.1.x86_64
    kernel-default-devel-2.6.31.8-0.1.1.x86_64
    kernel-desktop-devel-2.6.31.8-0.1.1.x86_64
    kernel-firmware-20090821-4.1.noarch
    kernel-desktop-2.6.31.8-0.1.1.x86_64
    nfs-kernel-server-1.1.3-21.3.1.x86_64
    linux-kernel-headers-2.6.31-3.4.noarch
    kernel-syms-2.6.31.8-0.1.1.x86_64
    kernel-xen-devel-2.6.31.8-0.1.1.x86_64
    kernel-debug-devel-2.6.31.8-0.1.1.x86_64
    kernel-source-2.6.31.8-0.1.1.noarch

    You should be able to remove all the red, unless you know you need any of them??
    In software management search for and mark to delete each. In the process ignore all the error boxes, just cancel it and move on until all the above are marked. At this point tell me if when marking the last one in the list still brings an error. You can save the error with the 'expert' button and post it here.
    Don't apply this until you confirm with me
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,764

    Default Re: remove default kernel?

    There is a problem with the VMware Server install script and the newer kernels. And that is the error that is thrown even if the headers are installed correctly. There is some work arounds and VMware does not seem in a hurry to fix the problem. I simply gave up and installed VirtualBox instead. It works/installs fine in 11.2

    If you must use VMware Server then look here in the forms there are several work arounds that seem to work for people. Once installed I hear it runs fine.

  6. #6

    Default Re: remove default kernel?

    Got them all tagged and ready to remove. Software Manager does insist that it is going to install kernel-default-base, though.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: remove default kernel?

    Go to the view tab 'Installation Summary'
    and uncheck the kernel-default-base

    see what you get then
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: remove default kernel?

    OK. The kernel-default-base package is being motivated by the nvidia driver. Trying to uninstall the package gives a set of options related to nvidia. Seems like the correct answer is to deinstall nvidia, and the reinstall it with the remaining kernel?

    [Actually, I think the nvidia driver is installed for the desktop kernel as well.....]

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: remove default kernel?

    Try that then. Remove all the nvidia packages the same way, see what it does and report back
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: remove default kernel?

    It seems like the mission has been accomplished.

    Code:
    rpm --query --all '*kernel*'
    kernel-desktop-devel-2.6.31.8-0.1.1.x86_64
    kernel-firmware-20090821-4.1.noarch
    kernel-desktop-2.6.31.8-0.1.1.x86_64
    linux-kernel-headers-2.6.31-3.4.noarch
    kernel-source-2.6.31.8-0.1.1.noarch
    grub no longer has an entry for the default kernel. The desktop kernel booted normally, with nvidia (I did not have to go back and reinstall it). All seems to be working.

    Thanks for your help!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •