Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Bluefish problem - libpcre.pc

Hybrid View

  1. #1
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Unhappy Bluefish problem - libpcre.pc

    Hi all:

    I'm trying to install Bluefish (html editor) but am running into a problem. Compiling from source (it isn't in the repos, sigh) I get a configure error that it can't find libpcre.pc (libpcre-dev). Using Yast2, I've searched for libpcre, libpcre.pc, libpcre-dev without results.
    Code:
    checking for pcre-config... no
    configure: error: pcre-config/libpcre.pc not found. Install libpcre3-dev or similar.
    laptop:/temp/bluefish-unstable-1.3.8 #
    This has occurred in both bluefish 1.3.8 and 2.0.0.rc1.

    My repos are the oss, non-oss, packman, suse-community, update, debug, kde-core, and kde-community). Also source, install-media, and videolan which are disabled.

    Searching the forums, I find several references to Bluefish, but nothing about problems installing it.

    Any suggestions would be greatly appreciated.

    Thanks, Tom

  2. #2
    palladium NNTP User

    Default Re: Bluefish problem - libpcre.pc

    > Searching the forums, I find several references to Bluefish, but
    > nothing about problems installing it.


    that is because it *is* in the repos!
    open YaST > Software Management > Search block, enter bluefish click
    click done done..

    if not something is BAD wrong with your YaST...what OS version and are
    KDE or Gnome or what!

    well, see here: http://software.opensuse.org/search
    1. type bluefish
    2. spin the dial to your OS
    3. reading top to bottom click the FIRST "1-Click Install" button you
    see (right side of center column....clean your glasses '44)

    BUT, you have FAR too many repos: trim them down to four enabled (you
    can have all you want listed, but only enable four unless you have a
    specific need....read which four and why in the *IMPORTANT* note here:
    http://forums.opensuse.org/new-user-...ml#post2058902

    --
    palladium '46

  3. #3
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Angry Re: Bluefish problem - libpcre.pc

    Quote Originally Posted by palladium View Post
    > Searching the forums, I find several references to Bluefish, but
    > nothing about problems installing it.


    that is because it *is* in the repos!
    open YaST > Software Management > Search block, enter bluefish click
    click done done..

    if not something is BAD wrong with your YaST...what OS version and are
    KDE or Gnome or what!

    well, see here: Software.openSUSE.org
    1. type bluefish
    2. spin the dial to your OS
    3. reading top to bottom click the FIRST "1-Click Install" button you
    see (right side of center column....clean your glasses '44)

    BUT, you have FAR too many repos: trim them down to four enabled (you
    can have all you want listed, but only enable four unless you have a
    specific need....read which four and why in the *IMPORTANT* note here:
    NEW Users - openSuse Pre-install (general) PLEASE READ - openSUSE Forums


    --
    palladium '46
    It is NOT in the normal repos: check out these pics:
    HTML Code:
    [URL=http://hostmyjpg.com][IMG]http://img.hostmyjpg.com/164726798_bluefish.jpeg[
    /IMG][/URL]
    HTML Code:
    [URL=http://hostmyjpg.com][IMG]http://img.hostmyjpg.com/897225688_bluefish1.jpeg
    [/IMG][/URL]
    Yes, I do have more repos enabled, but that is because I'm searching for bluefish.

    Your sarcastic response is not appreciated!!!!
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  4. #4
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Default Re: Bluefish problem - libpcre.pc

    Since you apparently know which repository bluefish is in, why not share that knowledge.
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,707
    Blog Entries
    15

    Default Re: Bluefish problem - libpcre.pc

    Quote Originally Posted by tommyttt
    Since you apparently know which repository bluefish is in, why not share
    that knowledge.
    Hi
    Did you follow the search link provided rather than using YaST?

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.39-0.3-default
    up 3 days 2:29, 4 users, load average: 5.35, 6.00, 4.42
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  6. #6
    palladium NNTP User

    Default Re: Bluefish problem - libpcre.pc

    > Your sarcastic response is not appreciated!!!!

    it was absolutely not my intention to sarcastic!

    i didn't see you 'overly sensitive' placard..

    excuse me for trying to be helpful! i won't bother you again.

    --
    palladium

  7. #7
    Join Date
    Sep 2009
    Location
    Seattle, WA
    Posts
    276

    Thumbs up Re: Bluefish problem - libpcre.pc

    Quote Originally Posted by palladium View Post
    > Your sarcastic response is not appreciated!!!!

    it was absolutely not my intention to sarcastic!

    i didn't see you 'overly sensitive' placard..

    excuse me for trying to be helpful! i won't bother you again.

    --
    palladium
    Sorry for the snippy response. Made on a bad day when I didn't take time to sit back and analyze things thouroughly.
    on me.

    I did find bluefish in the education repo which I didn't have in my repo list. It is now but not enabled.

    Thanks for the tip about searching the repos, I'd forgotten about that. Getting too darn old.

    Tom
    Tom Taylor - retired penguin
    AMD Phenom II x4 955 -- 4GB RAM -- 2x1.5TB sata3
    openSUSE 12.3x86_64 openSUSE 13.1-M2x86_64
    KDE 4.8.5, FF 14.0.1 - 8- KDE 4.10.0, FF 20.0
    registered linux user 263467

  8. #8
    JosephKK NNTP User

    Default Re: Bluefish problem - libpcre.pc

    On Sat, 09 Jan 2010 04:56:03 GMT, tommyttt <tommyttt@no-mx.forums.opensuse.org> wrote:

    >
    >palladium;2100883 Wrote:
    >> > Searching the forums, I find several references to Bluefish, but
    >> > nothing about problems installing it.

    >>
    >> that is because it *is* in the repos!
    >> open YaST > Software Management > Search block, enter bluefish click
    >> click done done..
    >>
    >> if not something is BAD wrong with your YaST...what OS version and are
    >> KDE or Gnome or what!
    >>
    >> well, see here: 'Software.openSUSE.org'
    >> (http://software.opensuse.org/search)
    >> 1. type bluefish
    >> 2. spin the dial to your OS
    >> 3. reading top to bottom click the FIRST "1-Click Install" button you
    >> see (right side of center column....clean your glasses '44)
    >>
    >> BUT, you have FAR too many repos: trim them down to four enabled (you
    >> can have all you want listed, but only enable four unless you have a
    >> specific need....read which four and why in the *IMPORTANT* note here:
    >> 'NEW Users - openSuse Pre-install (general) PLEASE READ - openSUSE
    >> Forums' (http://tinyurl.com/yhf65pv)
    >>
    >>
    >> --
    >> palladium '46

    >
    >It is NOT in the normal repos: check out these pics:

    >
    >'[image: http://img.hostmyjpg.com/164726798_bluefish.jpeg[
    >/IMG]' (http://hostmyjpg.com)
    >
    >
    >'[IMG]http://img.hostmyjpg.com/897225688_bluefish1.jpeg
    >]' (http://hostmyjpg.com)
    >
    >Yes, I do have more repos enabled, but that is because I'm searching
    >for bluefish.
    >
    >Your sarcastic response is not appreciated!!!!


    Someone should have told you about webpin.

    It would promptly lead you here:

    http://packages.opensuse-community.o...o=openSUSE_112


  9. #9
    palladium NNTP User

    Default Re: Bluefish problem - libpcre.pc

    JosephKK wrote:

    > Someone should have told you about webpin.


    i did, see:

    >>> (http://software.opensuse.org/search)
    >>> 1. type bluefish
    >>> 2. spin the dial to your OS
    >>> 3. reading top to bottom click the FIRST "1-Click Install" button

    you see


    --
    palladium

  10. #10
    JosephKK NNTP User

    Default Re: Bluefish problem - libpcre.pc

    On Sun, 17 Jan 2010 09:16:54 GMT, palladium <palladium@no-mx.forums.opensuse.org> wrote:

    >JosephKK wrote:
    >
    >> Someone should have told you about webpin.

    >
    >i did, see:
    >
    >>>> (http://software.opensuse.org/search)
    >>>> 1. type bluefish
    >>>> 2. spin the dial to your OS
    >>>> 3. reading top to bottom click the FIRST "1-Click Install" button

    >you see


    That build service is pretty neat as well. I notice it will build for
    several other label out of date distributions but not for Suse out of
    date versions. That is kind of strange.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •