Results 1 to 7 of 7

Thread: dosemu not run

  1. #1

    Default dosemu not run

    Hi,
    dosemu start via Konsole give me the message:
    > dosemu
    LOWRAM mmap: Das Argument ist ungueltig
    Speicherzugriffsfehler

    How can I resolve this problem?

    with regards
    Rummelfliege

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: dosemu not run

    The solution is in 2 parts:

    First, do this:

    su -c 'echo "vm.mmap_min_addr = 0" >> /etc/sysctl.conf'

    Enter rootpassword. This adds a the lowram setting required to the system control file sysctl.conf.

    Next you have to disable Apparmor completely:

    kdesu 'kwrite /boot/grub/menu.lst'

    Enter rootpassword. In kwrite, add "apparmor=0" (without quotes, =ZERO) to the boot options line for your default choice.

    Now reboot, and dosemu will work.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: dosemu not run

    Hi,
    Quote Originally Posted by Knurpht View Post
    The solution is in 2 parts:

    First, do this:

    su -c 'echo "vm.mmap_min_addr = 0" >> /etc/sysctl.conf'

    Enter rootpassword. This adds a the lowram setting required to the system control file sysctl.conf.

    Next you have to disable Apparmor completely:

    kdesu 'kwrite /boot/grub/menu.lst'

    Enter rootpassword. In kwrite, add "apparmor=0" (without quotes, =ZERO) to the boot options line for your default choice.

    Now reboot, and dosemu will work.
    Thanks - it works fine!

    with regards
    Rummelfliege

  4. #4

    Default Re: dosemu not run

    Hi, sorry for me english.
    not yet know much about linux, I'm learning recently.

    In that part of menu.lst is written apparmor = 0?

    Muchas Gracias

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: dosemu not run

    In the line specifying the kernel.

  6. #6
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    371

    Default Re: dosemu not run

    I tried this. Executing dosemu opens a window. When you type into the window the system bell squeals with every keystroke. How do I get dosemu to not squeal?
    The greatest obstacle to discovery is not ignorance, it is the illusion of knowledge.
    Daniel J. Boorstin US Patent Office

  7. #7

    Cool Re: dosemu not run

    Hi, edit the file dosemu.conf in /etc/dosemu and go to speaker and soun settings, there you has to insert $_speaker = "", con eso se termino el sonido molesto del teclado y no chilla mas. Saludetes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •