Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 11.2, KDE 4.3 : Unable to disable display power management

  1. #1
    Join Date
    Jan 2010
    Posts
    5

    Default 11.2, KDE 4.3 : Unable to disable display power management

    Hello,
    I want to disable display power management.

    I tried to achieve this by disabling 'Enable display power management' checkbox in the 'Configure Desktop -> Display -> Power Control' KDE configuration dialog.
    That didn`t help and display still goes into standby mode after some period of inactivity.
    Also, I tried to disable dpms functionality by calling 'xset -dpms'. That didn`t help too. Note that 'xset dpms force standby'
    command works as expected.

    So what I`m doing wrong ?

    Thank you

    /var/log/Xorg.0.log

  2. #2

    Default Re: 11.2, KDE 4.3 : Unable to disable display power manageme

    Hi kxx,

    If I am not too far off the target there is another Power Management option in Advanced tab, where you can tweak the profile that is being used and prevent display power management in the profile. I believe that should take care of the display going into standby.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: 11.2, KDE 4.3 : Unable to disable display power manageme

    You really have to go thru all the options, they are scattered all over the place.
    Check for this one:
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: 11.2, KDE 4.3 : Unable to disable display power manageme

    Quote Originally Posted by caf4926 View Post
    You really have to go thru all the options, they are scattered all over the place.
    Check for this one:
    Yeh its a real pain to get all the power settings right, but this is more fault of KDE for being so spread out on its power settings.
    https://features.opensuse.org/308357

  5. #5
    Join Date
    Jan 2010
    Posts
    5

    Default Re: 11.2, KDE 4.3 : Unable to disable display power manageme

    Quote Originally Posted by pavibhai View Post
    Hi kxx,

    If I am not too far off the target there is another Power Management option in Advanced tab, where you can tweak the profile that is being used and prevent display power management in the profile. I believe that should take care of the display going into standby.
    I did the following changes using the "Power Management" KDE configuration dialog:

    - disabled "Let PowerDevil manage screen powersaving" checkbox
    - used "Presentation" profile for all profile assignments
    - modified "Presentation" profile in the following way :
    a) disabled "Enable display power management" checkbox
    b) set "Do nothing" action for any system condition available
    c) disabled "Dim display when idle for more than" checkbox

    That didn`t help..

    I`ve solved my problem by disabling PowerDevil service in the 'SystemSettings -> Advanced -> Service Manager' KDE configuration dialog. Generally, it doesn`t looks like a proper solution but I`m satisfied with it.

  6. #6
    Join Date
    Jan 2010
    Posts
    5

    Default Re: 11.2, KDE 4.3 : Unable to disable display power manageme

    Quote Originally Posted by kxx View Post
    I did the following changes using the "Power Management" KDE configuration dialog:

    - disabled "Let PowerDevil manage screen powersaving" checkbox
    - used "Presentation" profile for all profile assignments
    - modified "Presentation" profile in the following way :
    a) disabled "Enable display power management" checkbox
    b) set "Do nothing" action for any system condition available
    c) disabled "Dim display when idle for more than" checkbox

    That didn`t help..

    I`ve solved my problem by disabling PowerDevil service in the 'SystemSettings -> Advanced -> Service Manager' KDE configuration dialog. Generally, it doesn`t looks like a proper solution but I`m satisfied with it.
    False positive, disabling PowerDevil KDE service didn`t help too...

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: 11.2, KDE 4.3 : Unable to disable display power manageme

    You would need to reboot
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Jan 2010
    Posts
    5

    Default Re: 11.2, KDE 4.3 : Unable to disable display power manageme

    Quote Originally Posted by caf4926 View Post
    You would need to reboot
    Tried this, it didn`t change current behaviour.

  9. #9

    Default Re: 11.2, KDE 4.3 : Unable to disable display power manageme

    Quote Originally Posted by kxx View Post
    I tried to achieve this by disabling 'Enable display power management' checkbox in the 'Configure Desktop -> Display -> Power Control' KDE configuration dialog.
    Strange, because doing that works just fine for me (11.2, kde 4.3.4).
    Before that, I tried to change it over the Power Management option on the Advanced tab, just to find that it didn't do anything at all, no matter what I set.
    OpenSuse 11.2 x64 + Kde 4.4.2 Release 234

  10. #10
    Join Date
    Jan 2010
    Posts
    5

    Default Re: 11.2, KDE 4.3 : Unable to disable display power manageme

    There is a mistake in the problem description.
    After timeout, my LCD display becomes black, but backlight is still turned on.

    So, I had to disable KDE screen saver
    Of course, it is my mistake, but it was not obvious for me because by default, screen saver type is set to "Blank Screen" and it is not required to enter password to exit screen saver.
    I think that it would be better for default screen saver type to be set to some kind of animation to make it obvious for the user what`s going on...

    However, that is not enough when you want to use other DE too

    X offers two modes of screen blanking: BlankTime and DPMS (both are enabled by default on my system)
    More info on this topic can be found here x-screen-blanking.
    1) BlankTime
    This feature simply makes screen black, it doesn`t turn off backlight and has nothing to do with powersaving.
    Any DE that provides the way to configure screensaver is expected to disable this (probably useless) feature on startup (KDE does it).
    2) DPMS (display power management)
    In case of DE provides the way to configure this feature, it is expected to restore configured DPMS settings (or disable it) on startup.
    DPMS settings are not shared between differrent DE.

    In case of your DE doesn`t provide the way to configure DPMS and screensaver, you need to call "xset s 0 0" to disable BlankTime and "xset -dpms" to disable DPMS.
    Simply running these commands on system startup/user login is not a proper solution because on startup, each DE that provides the way to configure DPMS/screensaver
    will override these settings according to its specific configuration.

    I`ve summarized my experience to make it useful for an ordinary desktop user that simply wants to be able to watch movies without being interrupted :

    1. Does your DE allows you to configure sceensaver ? If so, disable it.
    KDE-specific way to perform this :
    - use 'System settings' -> 'Desktop' -> 'ScreenSaver' configuration dialog
    2. Does your DE provides the way to configure DPMS ? If so, disable these features.
    KDE-specific way to perform this :
    - disable DPMS in the 'System settings' -> 'Display' -> 'Power control' configuration dialog ;
    - do the following changes using 'System settings' -> 'Advanced' -> 'Power Management' configuration dialog :
    a) disable 'Let PowerDevil manage screen powersaving' checkbox
    b) change profile assignments for any system condition to the same profile (for example, 'Presentation' profile)
    c) edit selected profile : go to the 'Screen' profile configuration section and disable 'Enable display power management' checkbox
    3. In case of (1) or (2) is TRUE, logout from your DE and login back
    4. "xset q" command reports that DPMS feature is disabled and screen saver timeout is zero ? If not, you need to find the DE-specific way to execute "xset -dpms; xset s 0 0;" command on startup of your DE.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •