Results 1 to 5 of 5

Thread: Preventing Powerdevil from changing brightness

  1. #1
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Question Preventing Powerdevil from changing brightness

    Is there a way to prohibit Powerdevil from messing with the screen brightness?

    I already tried to disable the tick box "Let PowerDevil manage screen powersaving" but that does not fix it. It still controls brightness.


    My LCD screen brightness is controlled by an ambient sensor built into the laptop, and this used to work fine with previous Suse versions. However, with 11.2 powerdevil became capable of setting the screen brightness, which is very annoying. It seems to prevent the ambient sensor from setting the brightness, and it also causes the brightness to jump when the battery goes down. Very annoying.

    I do want Powerdevil to control the screen saver and whether the LCD goes black or not after some time. I also don't mind LCD dimming when the machine is not in use after a while. I just want Powerdevil to leave the brightness setting alone when changing power profiles for whathever reason.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Preventing Powerdevil from changing brightness

    The settings are all over the place
    Check this one
    ImageBam - Fast, Free Image Hosting and Photo Sharing
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Default Re: Preventing Powerdevil from changing brightness

    No, the PowerControl setting in KDE System Settings is overridden by PowerDevil. I already have it disabled.

    Furthermore, I do want Standby/Suspend and this setting only handles that. Disabling Standby/Suspend in PowerDevil still allows PowerDevil to change LCD brightness.

    I just don't want to be blinded by my LCD if the battery goes low: Its dark and I reduce brightness to minimum. Battery goes low and PowerDevil changes brightness to 50%, which is way to bright in a dark condition, and way too low in daylight.

    PowerDevil should really let the ambient light sensor do its job.

  4. #4
    Join Date
    Jun 2008
    Location
    Tallinn, Estonia
    Posts
    226

    Default Re: Preventing Powerdevil from changing brightness

    Pretty old thread but the problem is still topical.

    I miss that "Don't touch my brightness" option too.

    I have found a couple of interesting bug reports:
    https://bugs.kde.org/show_bug.cgi?id=216675
    https://bugs.kde.org/show_bug.cgi?id=173930
    https://bugs.kde.org/show_bug.cgi?id=198463

    And I have written some comments myself, so we'll see how things develop.

    I will post if I find something.

  5. #5
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Default Re: Preventing Powerdevil from changing brightness

    Thanks for the links!

    There is also this old blog post about the future of power devil being event driven rather than profile oriented, which seems to be a very good idea to me, that would also resolve the issue. However, I could not find any further information on whether that suggestion is still pursued.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •