Results 1 to 6 of 6

Thread: Unable to set external mouse in System Settings

  1. #1

    Default Unable to set external mouse in System Settings

    When I connect my logitech cordless optical mouse to my laptop I am unable to access it's settings under system settings. The setting options are greyed out and it says
    You have a Logitech Mouse connected, and libusb was found at compile time, but it was not possible to access this mouse. This is probably caused by a permissions problem - you should consult the manual on how to fix this.


    How or where can I set the permissions so that I am able to access the mouse settings? I've googled around and found lots of references to the above message but no solutions.

    The mouse is one of those optical wireless (radio) mice
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  2. #2

    Default Re: Unable to set external mouse in System Settings

    An update. Becoming su and then running systemsettings from the cli gives me access to the settings in the MX1000 laser mouse tab.

    Anyone know where the permissions that govern this may be hidden? It doesn't seem to make sense to have access to all the mouse settings except the ones specific to the mouse model that's plugged in.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Unable to set external mouse in System Settings

    It's strange because I can just plug stuff like that in and it works, no configuring needed.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Unable to set external mouse in System Settings

    Yeah, I guess you're lucky. This seems fairly common (in other distros too) judging by the number of hits in google. Trouble is I cannot find any real solution.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  5. #5
    Join Date
    Jun 2008
    Location
    Sarasota, Florida usa
    Posts
    807

    Default Re: Unable to set external mouse in System Settings

    How are your batteries
    did you hit the connect buttons on the transceiver and mouse

  6. #6

    Default Re: Unable to set external mouse in System Settings

    Batteries are fine. Renogotiating the comms between the transceiver and mouse makes no difference and the mouse works fine.

    When I access the mouse settings as su then all the settings are available and battery indicator shows 71%. It's only disabled when accessing the settings as normal user and I get wat's displayed in my screenshot.

    Also, with the external mouse connected system settings always crashes when closing it after accessing the mouse config tab. I've since found that the crashing is a bug and has been reported already.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •