Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: spindown HD in openSUSE 11.2

  1. #1

    Default spindown HD in openSUSE 11.2

    I've looked at a few ways to spindown my second HD but am having a hard time trying to keep it asleep. Something in the system seems to wake it up about every 15 minutes. In my 10.1 install, I was able to keep the drive asleep until *I* accessed it. In 11.2, I'm having problems. (Unfortunately I can't remember how I had set it up in 10.1.)

    I've tried the "spindown" package, which will spindown the drive, but it still wakes up 15 minutes later. I decided to go with a more simple method:

    hdparm -S 120 /dev/sdb

    in /etc/init.d/boot.local. This works, but still has the same wake up problem.

    I've added "noatime" and "nodiratime" flags in /etc/fstab for the partitions, but that didn't seem to help.

    Any ideas? What's the proper modern/11.2 method?

    Thanks!

    Vinh

  2. #2

    Default Re: spindown HD in openSUSE 11.2

    After doing some more research, I found this sequence of commands to be run as super-user:

    echo 1 > /proc/sys/vm/block_dump
    while ( ! dmesg -c | grep sdb ); do sleep 1; done
    echo 0 > /proc/sys/vm/block_dump

    The first command dumps all disk access messages to /var/log/messages. The next command searches for accesses to sdb drive and prints them. The last command turns off the disk access logging. The main caveat is that this will write a ton of messages to /var/log/messages. I did these commands right after the drive woke up to see what processes were accessing the drive.

    I found that a daemon, smartd, was accessing the drive sdb, so I looked that up. smartd is a service to test the reliability of the drives. Since my sdb drive doesn't really support such a capability, I saw no need for it. I couldn't figure out a way to disable smartd for sdb alone so I decided to disable smartd altogether.

    From YaST, I selected System->System Services (Runlevel). I scrolled down to smartd and clicked on Disable. I accepted the change and that was it.

    My drive has been quiet until I've accessed it.

  3. #3
    palladium NNTP User

    Default Re: spindown HD in openSUSE 11.2

    i think this is just a wonderful thread (thanks for coming back and
    filling us in) and i just wanna throw some words (tags?) into the
    thread's text so maybe more folks can find it with a forum/google search:

    laptop power saving battery extending hard drive harddrive wake up
    wake-up spin down spin-down sleep idle rest 11.2

    i hope someday someone (since the community uses so much green ink)
    will consolidate all of these tips into how to howto how-to ;-)

    solved [SOLVED]

    --
    palladium

  4. #4
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: spindown HD in openSUSE 11.2

    [QUOTE=palladium;2100359]i think this is just a wonderful thread (thanks for coming back and
    filling us in) and i just wanna throw some words (tags?) into the
    thread's text so maybe more folks can find it with a forum/google search:

    laptop power saving battery extending hard drive harddrive wake up
    wake-up spin down spin-down sleep idle rest 11.2

    /QUOTE]

    Agree with the sentiment,but what makes you think it's a laptop???
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  5. #5
    palladium NNTP User

    Default Re: spindown HD in openSUSE 11.2

    gminnerup wrote:
    > Agree with the sentiment,but what makes you think it's a laptop???


    didn't think it was (or was not)...but, have seen many laptop owners
    here asking how to keep their hard drives asleep..

    --
    palladium

  6. #6

    Default Re: spindown HD in openSUSE 11.2

    I appreciate the thanks. I think people who post questions should summarize what worked for them. During this "quest" I found many suggestions given and the original posters would just say "thanks" in the end and not specify which of the solutions worked for them. I personally like to "close out" my questions with a summary.

    -----

    For people with laptops/netbooks, I think the power management software in openSUSE works quite nice, but I've actually never bothered to see if my netbook drive spins down while idle. (I know it does when I put the whole netbook to sleep though.)

    In this particular situation, I was trying to put to sleep a drive on a desktop, where power management software doesn't apply.

    I'm still curious as to what is the proper/modern way to spin down a drive: hdparm, spindown, ???

  7. #7
    palladium NNTP User

    Default Re: spindown HD in openSUSE 11.2

    linuxvinh wrote:
    > In this particular situation, I was trying to put to sleep a drive on a
    > desktop, where power management software doesn't apply.


    really? are you certain that power management software can 'see' if it
    is installed on a laptop *or* a desktop tower and then refuse to work
    depending on which it is??

    i don't think so! how would it know if the connected hard drive is in
    a portable package or one of these:
    https://infosecurity.us/images/first...erver_farm.jpg

    --
    palladium

  8. #8
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: spindown HD in openSUSE 11.2

    Power management very much applies to desktops. Mine "hibernates" (suspends to disk) a lot of the time, although "hibernation" seems an odd term to describe a means of stopping it from overheating in the Sydney summer...
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  9. #9

    Default Re: spindown HD in openSUSE 11.2

    How do I set power management software to only spindown a secondary drive while the rest of the system is in use?

  10. #10

    Red face Re: spindown HD in openSUSE 11.2

    Quote Originally Posted by linuxvinh View Post
    After doing some more research, I found this sequence of commands to be run as super-user:

    echo 1 > /proc/sys/vm/block_dump
    while ( ! dmesg -c | grep sdb ); do sleep 1; done
    echo 0 > /proc/sys/vm/block_dump

    The first command dumps all disk access messages to /var/log/messages. The next command searches for accesses to sdb drive and prints them. The last command turns off the disk access logging. The main caveat is that this will write a ton of messages to /var/log/messages. I did these commands right after the drive woke up to see what processes were accessing the drive.

    I found that a daemon, smartd, was accessing the drive sdb, so I looked that up. smartd is a service to test the reliability of the drives. Since my sdb drive doesn't really support such a capability, I saw no need for it. I couldn't figure out a way to disable smartd for sdb alone so I decided to disable smartd altogether.

    From YaST, I selected System->System Services (Runlevel). I scrolled down to smartd and clicked on Disable. I accepted the change and that was it.

    My drive has been quiet until I've accessed it.

    Hi
    Just upgraded my Laptop from Opensuse 12.1 to 12.1, for some reason my "hdparm -S 15 /dev/sda" setting did not work anymore. I "think" the upgrade activated the smartd service, after stopping it , my harddisk now spins down again.
    MANY THANKS FOR THE TIP
    Philippe

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •