AFAIK, I've seen various comments WRT opensuse 11.2, that people have been having problems which get them messages such as I've been getting. However those situations involved trying to su to another user. In my case, I'm just running a shell script to start Konsole, as myself, not another user.

When I click on a panel icon to launch Konsole, I get a pop-up message with a frame header labelled
"Sorry - Plasma Workspace". The pop-up window contains a yellow triangular "!" warning icon, followed by a message of the form
"KDEInit could not launch '...'".

I have long made use of a feature of Konsole that allowed the saving of profiles that included the ability to define multiple tabs in a single profile, with different tab labels, and initial directories, and other settings, for each tab. I had my Konsole app configured to come up with several tabs defined with specific names and initial working directories. I found it extremely handy!

Very sadly , that capability *appears* to have been removed from Konsole, and replaced with a much more limited profile mechanism, such that a single profile applies to all tabs.

In order to have a Konsole that comes up configured the way I want, I created a shell script containing lines like:

konsole --new-tab --workdir $HOME/Documents -p LocalTabTitleFormat=doc
konsole --new-tab --workdir $HOME/Documents/lists -p LocalTabTitleFormat=lists
konsole --new-tab --workdir $HOME/src -p LocalTabTitleFormat=src

I add an icon to the panel to launch Konsole. I then create my own user specific "konsole.desktop" file, changing the settings to launch the shell script.

This has worked fairly well under opensuse, since the time the more full fledged profile capability was dropped, until I started using the GA of 11.2.

With 11.2 the shell script is actually launched, Konsole usually comes up the way I want, with several tabs predefined with different names and initial working directories. But, even though the shell script was successfully launched and Konsole set up the way I want it, with 11.2, I get the pop-up message, claiming that the shell script wasn't launched.

Since apart from the message, everything seems to work pretty much the way it's supposed to, it's just an annoyance, so far. But it seems to suggest that something in the application launching mechanism is different with 11.2. Is there something special with kdeinit4 under opensuse 11.2, that I need to do to report that a launch was successful?

Any assistance would be greatly appreciated.