Results 1 to 10 of 10

Thread: 1 sec delay - Minimized window to foreground

  1. #1

    Default 1 sec delay - Minimized window to foreground

    Hi,

    I'm Linux beginner at all and I've installed OpenSUSE with GNOME a few days ago.

    I have found that if I minimize window and then I want to transfer it to foreground, it takes about 1 second delay, what is rally too much for me. If window is not minimized, only behind some other windows, there is no delay.

    Could you please suggest me how to fix this delay?

    Thanks very much!

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,663
    Blog Entries
    14

    Default Re: 1 sec delay - Minimized window to foreground

    Happy New Year and welcome to the forum.

    Your info is a bit on the low hand. Is this about "un-minimalizing the window hidden in the task manager?

    What is the video-card used? Is 3D support enabled?
    Which openSUSE ?
    32/64 bit?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: 1 sec delay - Minimized window to foreground

    This is my PC: MS-6585, Pentium4 2.8GHz, 1GB RAM, HD 2600XT AGP 256MB
    so I have 32bit. My OpenSUSE is 11.2

    I've installed ATI Drivers following "Easy way" described here ATI - openSUSE and "glxgears" runs fine, so I guess that 3D acceleration is enabled.
    EDIT: okey, glxgears doesn't run fine, in resolution 1024x768 I've got this output
    Code:
    ...
    82 frames in 5.1 seconds = 16.201 FPS
    83 frames in 5.0 seconds = 16.597 FPS
    95 frames in 5.0 seconds = 18.886 FPS
    89 frames in 5.0 seconds = 17.780 FPS
    ...
    How can I test if 3D support is really enabled?

    Yes, and delay appears when un-minimizing window hidden in task bar.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,663
    Blog Entries
    14

    Default Re: 1 sec delay - Minimized window to foreground

    glxinfo | grep direct

    This should result in something like this:
    direct rendering: Yes
    GL_EXT_Cg_shader, GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,

    The first line should be the same, the rest might differ.

    Mind, you're using an old AGP card. Don't expect the driver(s) to improve performance to a level the card simply does not have.

    You might find solutions in turning off some of the desktop effects.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: 1 sec delay - Minimized window to foreground

    Quote Originally Posted by trebisuse View Post
    Hi,

    I'm Linux beginner at all and I've installed OpenSUSE with GNOME a few days ago.

    I have found that if I minimize window and then I want to transfer it to foreground, it takes about 1 second delay, what is rally too much for me. If window is not minimized, only behind some other windows, there is no delay.

    Could you please suggest me how to fix this delay?

    Thanks very much!
    Run LiveCD with KDE. Don't install the OS, but install the driver the same way. See whether the delay improves.

  6. #6

    Default Re: 1 sec delay - Minimized window to foreground

    I have got only 1 line
    Code:
    trebi@linux-398t:~> glxinfo | grep direct
    direct rendering: Yes
    okey I'll try KDE LiveCD

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,663
    Blog Entries
    14

    Default Re: 1 sec delay - Minimized window to foreground

    @Zstefan: could you explain your post. I don't get it at all, and doubt that the OP will.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,663
    Blog Entries
    14

    Default Re: 1 sec delay - Minimized window to foreground

    What's it like if you disable the desktop effects?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9

    Default Re: 1 sec delay - Minimized window to foreground

    great, disabling desktop effects helps for windows :-), now they appear immediately, but there is still problem with "Computer button" (in left side of task bar), the menu will appear still after 1 sec after click on it

  10. #10

    Default Re: 1 sec delay - Minimized window to foreground

    Quote Originally Posted by Knurpht View Post
    @Zstefan: could you explain your post. I don't get it at all, and doubt that the OP will.
    The issue does not seem to be in driver, rather than in window manager.

    So trying KDE will open a possibility for hardware to work normally.

    Trying from Live CD will bypass the need to install the OS just for testing.

    Later, if successful, a full KDE install can be performed.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •