Results 1 to 5 of 5

Thread: GTK style not being applied to FF, TB3.0 and gimp

  1. #1
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default GTK style not being applied to FF, TB3.0 and gimp

    I'm having trouble to get Firefox and Thunderbird to conform to the GTK theme style. For some reason the scrollbars will not change accordingly and continue to have the Oxygen themes v < ^ > arrowheads and rounded slider.

    In systemsettings, I've set the style to qtcurve and made my qtcurve configurations. I then set gtk to style to qtcurve under gtk styles and fonts. But for some reason the changes are not being applied to Firefox or Thunderbird nor Gimp for that matter. They do however get applied to openoffice which I believe is also a gtk application.

    See screen shots below

    Scrollbars as applied to native KDE apps e.g. Dolphin (correct)


    Scrollbars as applied to openoffice writer (correct)


    Scrollbars as applied to Firefox, Thunderbird and Gimp (incorrect)


    In 11.1 the solution was to install kde4-gtk-qt-engine but I believe that has been abandoned as it was an ugly solution and has been replaced with kcm_gtk.

    Any clues as to how I can fix the applying of gtk styles to FF and TB?
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  2. #2
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: GTK style not being applied to FF, TB3.0 and gimp

    Any clues as to how I can fix the applying of gtk styles to FF and TB?
    I think you are seeing something similar to why my Evolution icons were all missing on KDE.

    Try this: create an empty file called .no-qtrc-to-gtkrc-mapping in your home folder:

    Code:
    cd ~
    touch .no-qtrc-to-gtkrc-mapping
    And then log off and back on (i.e. restart X). Now your GTK apps are no longer interfered with by KDE.

    Question for you: how do you apply a GTK style when on KDE? Which app do you launch? Do I need to install a package for that?
    Last edited by twelveeighty; 03-Jan-2010 at 19:56. Reason: fixed typo
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  3. #3
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: GTK style not being applied to FF, TB3.0 and gimp

    Thanks for the suggestion. It didn't work however.

    The thing is I want KDE's theme / style to be applied to the GTK apps. If I choose the GTK style like sonar then FF and TB do change accordingly. It seems that qtcurve, clearlooks, crux, grouche, etc. styles don't work for some reason.

    In answer to your question, in KDE go to system settings, then appearance, then gtk styles and fonts. You can set the gtk style for the gtk apps in the drop down. But for some reason only the sonar and mist seem to work from memory.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: GTK style not being applied to FF, TB3.0 and gimp

    Did you upgrade from a previous version? It may be some dross left in .kde4

    Try a new user and see if they have the same problem.

    I did a clean install and don't see this problem.

  5. #5
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: GTK style not being applied to FF, TB3.0 and gimp

    Yes it was a fresh install of 11.2. I then selectively copied over some configurations of the .kde4 folder from my 11.1 install.

    I tried creating a new user and the new user account has the same problem with the FF, TB and gimp scrollbars not adhering to the selected GTK style.

    I also tried deleting the .kde4 directory but that made no difference either.

    Can I ask which window style you are using and which gtk style you have set? If it's the default oxygen style then you won't really notice.

    Try the qtcurve style and set it to one of the predefined styles like Plastic. Then set the gtk style to qtcurve and see if FF's or gimp's scroll bars look like scrollbars in the dolphin image I posted above.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •