Results 1 to 7 of 7

Thread: need libXft.so.1

  1. #1

    Default need libXft.so.1

    I installed a software on opensuse 11.2 64 bit, but when i run it i have an error message: "error while loading shared libraries: libXft.so.1: cannot open shared object file: No such file or directory" . Where can I find this library? I tried through Yast but this library is not present

  2. #2
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: need libXft.so.1

    Install xorg-x11-libs. You could have found this with yast searching for libXft and enabling the option RPM 'provides'.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  3. #3

    Default Re: need libXft.so.1

    xorg-x11-libs is already installed, but it provides only libXft.so.2. Maybe I can link the execution of so.1 to so.2, but I don't know how to do this. Where can I find so.1 and how can I install it? thanks in advance.

  4. #4

    Default Re: need libXft.so.1

    I solved my problem: I simply copied libXft.so.2 from /usr/lib64 to the program's directory and renamed it as libXft.so.1. Now the program works, it doesn't seem to have problems or other issues. in that case I will ask your help again, but for now thank you for your support

  5. #5
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: need libXft.so.1

    Hi
    Having a closer look I found that 11.1 provides the following in directory /usr/lib:

    Code:
    ls -l /usr/lib/libXft*
    lrwxrwxrwx 1 root root    16  9. Jan 2009  libXft.so -> libXft.so.2.1.13
    lrwxrwxrwx 1 root root    13  9. Jan 2009  libXft.so.1 -> libXft.so.1.2
    -rwxr-xr-x 1 root root 59596  9. Dez 2008  libXft.so.1.2
    lrwxrwxrwx 1 root root    16  9. Jan 2009  libXft.so.2 -> libXft.so.2.1.13
    -rwxr-xr-x 1 root root 84176  9. Dez 2008  libXft.so.2.1.13
    In 11.2 they dropped libXft.so.1.2 and the links. You may add them manually and then run ldconfig as user root. Then you don't have to copy and rename the library. Please tell us if this works.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  6. #6

    Default Re: need libXft.so.1

    Hi
    I have the same problem. This is what I got:

    Code:
    linux-titj:/usr/lib # ls -l libXft*
    lrwxrwxrwx 1 root root    16 2009-12-25 19:01 libXft.so -> libXft.so.2.1.13
    lrwxrwxrwx 1 root root    16 2009-12-22 20:28 libXft.so.2 -> libXft.so.2.1.13
    -rwxr-xr-x 1 root root 84176 2009-10-19 13:21 libXft.so.2.1.13
    I don't have the libXft.so.1.2 in 11.2, so how do I link the so.1 to the so.2? Thanks in advance.

  7. #7
    Join Date
    Jul 2008
    Location
    in front of the keyboard
    Posts
    90

    Default Re: need libXft.so.1

    ln -s what where
    or use mc menu...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •