Results 1 to 2 of 2

Thread: GLIBCXX_3.4.11 not found

  1. #1

    Thumbs down GLIBCXX_3.4.11 not found

    copy the title of this thread into your google search window and see how many entries you get.

    In my case, running OpenSUSE 11.2 and trying to install OpenFOAM, as soon as I modify my .bashrc so I could source the environment variables for OpenFOAM, I get this most popular error message

    kde4-config: /home/xxxxx/OpenFOAM/ThirdParty-1.6.x/gcc-4.3.3/platforms/linux64/lib64/libstdc++.so.6: version 'GLIBCXX_3.4.11' not found (required by /usr/lib64/libkdecore.so.5)

    On this same OpenSUSE forum, there is a recommendation of installing libstdc++44 that is supposed to provide for this dependency,
    here is what I have

    rpm -q libstdc++44
    libstdc++44-4.4.1_20090817-2.3.4.x86_64

    I still get the error message and I am not able to compile my programme.

    Can anyone tell me Where can I get this GLIBCXX_3.4.11
    I will appreciate any hints

    Happy Holidays and good luvk to all

  2. #2

    Default Re: GLIBCXX_3.4.11 not found

    ZStefan has just replied to a thread you have subscribed to entitled - GLIBCXX_3.4.11 not found - in the Applications forum of openSUSE Forums.

    This thread is located at:
    GLIBCXX_3.4.11 not found - openSUSE Forums

    Here is the message that has just been posted:
    ***************
    The method that might help, sometimes, is the following.

    Create a link or copy the file to supply the installer with what is wants, since the coders weren't thinking forward.

    Here is an example. If you have

    /lib/liba.6.0.so

    meanwahile the installer seeks

    liba.5.2.so

    then in the /lib directory create a link:

    ln -s ./liba.6.0.so ./liba.5.2.so
    ***************

    ZStefan, I agree with your recommendation, but what library should I point at in order to get rid of this error messge

    Thanks for your reply and happy new year

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •