Results 1 to 5 of 5

Thread: KDE4, discs with same volume labels

  1. #1

    Default KDE4, discs with same volume labels

    Hello all,

    I'm curious if anyone else has run into this problem. My workstation has 2 optical disc drives. Today I placed a CD in each drive (virtually at the same time), but only one would appear.

    I realized that both CD-R discs have the same volume label. It was appearing that KDE was only showing the first (first to be inserted) disc in the removable devices icon/plasmoid on the task bar.

    I don't know if this is a KDE4 thing, or a Linux thing. I don't know much about the auto mounter, so maybe this is old news.

    I'm running openSUSE 11.2 x86_64. Thoughts?

    Thanks

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: KDE4, discs with same volume labels

    Did you try them one at a time?? ie let one mount before the next is inserted. I expect that having the same volume labels may be confusing things.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,003

    Default Re: KDE4, discs with same volume labels

    I am interested in the output of
    Code:
    mount
    at that moment in time.

    When no label is available devices are mounted on a directory with the name of the class of device (in your case cd) and when more are there this will be cd, cd-1, etc.

    But here we have labels. I always thought that in that case the same solution would be taken: label, label-1, etc.

    What does mount say?
    Henk van Velden

  4. #4

    Default Re: KDE4, discs with same volume labels

    Well, um...

    It may appear that, coincidentally, this may just be hardware. The closer I look, the more I'm seeing that one of my optical disc drives is being a bit finicky.

    dmesg shows IO errors on the first drive (SATA I) when I insert the CD-R discs, but the same discs read fine in the second drive (PATA). The first drive has been fine until now, so perhaps this is a manifestation of hardware failure.

    I need to fiddle with it more to see what is going on, as there may be no reason to question auto mounter or KDE at all.

    Will report more soon...

  5. #5

    Default Re: KDE4, discs with same volume labels

    So these two optical drives, I have... one is SATA and the other is PATA.

    I put a CD-R in the drive, and I get this:

    Code:
    [57461.120225] sr 2:0:1:0: [sr1] Unhandled sense code
    [57461.120242] sr 2:0:1:0: [sr1] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
    [57461.120255] sr 2:0:1:0: [sr1] Sense Key : Medium Error [current]
    [57461.120269] sr 2:0:1:0: [sr1] Add. Sense: L-EC uncorrectable error
    [57461.120282] end_request: I/O error, dev sr1, sector 827520
    [57461.120295] Buffer I/O error on device sr1, logical block 103440
    The CD-R reads fine, without a hitch, in the PATA drive.

    I dropped a DVD in the SATA drive, and it reads fine. I've tried other CD-R media... it seems to be hit and miss in terms of which work and which don't. But they all, DVD... CD-R, whatever, work in the PATA drive.

    So it seems we may just have a hardware problem. If I get more info on the actual mount issue, I'll post here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •