Results 1 to 3 of 3

Thread: VirtualBox Steals Audio

  1. #1
    Join Date
    Oct 2008
    Location
    Lakeland, Florida
    Posts
    235

    Default VirtualBox Steals Audio

    I'm currently dual booting openSUSE 11.2 (KDE) and Linux Mint 8.

    Running the same XP install in the same version of VB (3.1) with Pulse Audio chosen for the host audio in both SUSE and Mint.

    In Mint I can listen to music, watch Youtube in FF, and run XP with sound in VB.

    In openSUSE if I'm listening to music the audio won't load for XP in VB but if I pause what I'm listening to VB will steal the audio so I can't listen to my music any more.

    Is there a way to get openSUSE to behave the same as Mint?

    Is it because Mint uses Gnome?

    Thanks
    P5N-E SLI, Core2Duo E6850 @ 3GHZ, 2 GB DDR2 800MHZ
    EVGA 8800GTS 320MB, 2x320GB HDD
    Arctic Cooling Freezer 7 Pro

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,565
    Blog Entries
    38

    Default Re: VirtualBox Steals Audio

    Quote Originally Posted by markcynt View Post
    I'm currently dual booting openSUSE 11.2 (KDE) and Linux Mint 8.

    Running the same XP install in the same version of VB (3.1) with Pulse Audio chosen for the host audio in both SUSE and Mint.

    In Mint I can listen to music, watch Youtube in FF, and run XP with sound in VB.

    In openSUSE if I'm listening to music the audio won't load for XP in VB but if I pause what I'm listening to VB will steal the audio so I can't listen to my music any more.

    Is there a way to get openSUSE to behave the same as Mint?

    Is it because Mint uses Gnome?
    Note that pulse audio was introduced in part to help solve the issue where Linux sound servers/daemons would not allow multiple applications to share the same audio device.

    Since GNOME uses pulse audio more extensively than KDE, its possible Mint has a pulse audio implementation that actually works, and allows the sharing of the audio device between applications.

    In KDE on openSUSE, pulse audio has been disabled by default. I suspect this was because the openSUSE packager found that enabling it caused too many problems.

    In my case, I get around this limitation by selecting in Vritual Box, and selecting in all my applications settings/preferencs, the "alsa" API. By selecting that I am able to share audio between applications (such as VirtualBox).

  3. #3
    Join Date
    Oct 2008
    Location
    Lakeland, Florida
    Posts
    235

    Default Re: VirtualBox Steals Audio

    Yup, that worked.

    Thanks oldcpu.
    P5N-E SLI, Core2Duo E6850 @ 3GHZ, 2 GB DDR2 800MHZ
    EVGA 8800GTS 320MB, 2x320GB HDD
    Arctic Cooling Freezer 7 Pro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •