Hi there.

I'm having trouble with the charset on my OpenSuSE machine. For a long time I'd used OpenSuSE 9 to monitor my network with the Just For Fun Network Managemment System, or JFFNMS.

I've got a corrupted hard disk and had to rebuild the system. Only that now I'm using the OpenSuSE 11. It work very well and it's even using less RAM that it used to.

But, I'm getting these errors on the charset of the pages:

Bellow, is the page as it normally loads, with the browser using Ocidental ISO-8859-1 Charset.


Now, the page using UTF-8 Charset:


Here's the source code of the page:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "http://www.w3.org/TR/html4/frameset.dtd">
<!--
/*

* Copyright (C) <2002-2005> Javier Szyszlican <javier@szysz.com>
*
* This file is part of JFFNMS.
*
* JFFNMS is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
* the Free Software Foundation; either version 2 of the License, or
* (at your option) any later version.
*
* JFFNMS is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License for more details.
*
* You should have received a copy of the GNU General Public License
* along with JFFNMS; if not, write to the Free Software
* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
*/
-->
<html>
<head>
<title>
JFFNMS
</title>
<meta HTTP-EQUIV='Pragma' CONTENT='no-cache'>
<meta HTTP-EQUIV='Content-Type' CONTENT='text/html; charset=iso-8859-1'>
<meta HTTP-EQUIV='Content-language' CONTENT='en'>
<meta HTTP-EQUIV='Content-Style-Type' CONTENT='text/css'>
<meta HTTP-EQUIV='Content-Script-Type' CONTENT='text/javascript'>

<link rel='shortcut icon' type='image/x-icon' href='/images/jffnms.ico'>
<link rel='icon' type='image/x-icon' href='/images/jffnms.ico'>
<link rel='stylesheet' href='/default.css'>
<link rel='alternate' type='application/rss+xml' title='JFFNMS - 0.8.4 Events Feed' href='/events.php?view_type=rss'>
</head>
<frameset rows='20,*' frameborder='no' framespacing='0'>
<frame id='controls' name='controls' noresize scrolling='no' src='controls.php?'>
<frameset id='menu_frame' cols='*,0' frameborder='no' framespacing='1'>
<frame name='work' noresize scrolling='yes' src='blank.php?'>
<frame name='menu' scrolling='no' src='admin/menu.php?'>

</frameset>
</frameset>
</html>
The JFFNMS is configured as a VirtualHost, so I have add "AddDefaultCharset iso-8859-1" in the /etc/apache2/vhosts.d/jffnms.conf

Since it uses PHP, I uncommented the line
default_charset = "iso-8859-1"

Any help would be appreciated.