Results 1 to 9 of 9

Thread: KDE4 file-dialogue behavior

  1. #1

    Default KDE4 file-dialogue behavior

    Hello all.

    In KDE 4.3.4 (both in 11.1 and 11.2) either "save as" or "rename" file-dialogue shows only the file extension rather than the original whole name. This happens in both dolphin as well as kontact. Is there anyway to make it behave as it did in KDE 3.5 - i.e. when you select save as or rename, it displays the whole original name so you can make changes to the original name rather than having to type the new name from scratch.

    Thanks in advance.

    Woojin

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE4 file-dialogue behavior

    Not getting that.

    Post your repo info

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: KDE4 file-dialogue behavior

    Here's the "zypper lr -d" output. Sorry about the formatting...


    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------+-----------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
    1 | KDE:KDE4:STABLEesktop | KDE:KDE4:STABLEesktop | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2 |
    2 | Libdvdcss repository | Libdvdcss repository | Yes | Yes | 99 | rpm-md | Index of /pub/vlc/SuSE/11.2/ |
    3 | Openoffice | Openoffice | Yes | Yes | 99 | rpm-md | Index of /repositories/OpenOffice.org:/UNSTABLE/openSUSE_11.2 |
    4 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    5 | download.videolan.org-SuSE | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.2/ |
    6 | google | google | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/i386 |
    7 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/i386 |
    8 | http-download.opensuse.org-b0df512b | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
    9 | kde43 | kde43 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/43/openSUSE_11.2 |
    10 | mozilla | mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.2 |
    11 | openSUSE 11.2-0 | openSUSE 11.2-0 | No | No | 99 | yast2 | cd:/// |
    12 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    13 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    14 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    15 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE4 file-dialogue behavior

    Delete repo #2 and #9

    Now open Software management - Filter the view by Repo and as shown here with the kde stable desktop
    http://public.bay.livefilestore.com/...itch%20kde.png

    When you have done that Use Software Management and this time filter to View by Packman and do this
    http://public.bay.livefilestore.com/...er%20Final.png

    Logout and back in
    Report back here
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: KDE4 file-dialogue behavior

    Followed the instruction as suggested, and it's still behaving the same way. From dolphin, when you click "rename", I get only the extension (ex: .pdf) rather than the original name. Here's the zypper lr -d output again.

    Thanks.

    Woojin



    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------+-----------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
    1 | KDE:KDE4:STABLEesktop | KDE:KDE4:STABLEesktop | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2 |
    2 | Openoffice | Openoffice | Yes | Yes | 99 | rpm-md | Index of /repositories/OpenOffice.org:/UNSTABLE/openSUSE_11.2 |
    3 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    4 | download.videolan.org-SuSE | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.2/ |
    5 | google | google | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/i386 |
    6 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/i386 |
    7 | http-download.opensuse.org-b0df512b | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
    8 | mozilla | mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.2 |
    9 | openSUSE 11.2-0 | openSUSE 11.2-0 | No | No | 99 | yast2 | cd:/// |
    10 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
    11 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    12 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    13 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE4 file-dialogue behavior

    I didn't notice before but I would remove repo 2 and repo 4

    Not sure it will fix your issue. But you really don't want unstable repo's and certainly you don't need VLC repo.

    Once done you may want to roll back a lot of RED packages in software management, filter to System
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: KDE4 file-dialogue behavior

    Actually I was wrong earlier when I said it happens in both 11.1 and 11.2. It only happens on 11.2 machine. Both had same repo's.

    I'll try reinstalling 11.2 and start adding one repo's at a time and see when the issue shows up, if at all.

    Thanks

    Woojin

  8. #8

    Default Re: KDE4 file-dialogue behavior

    Ok. I think I made some progress in tracking down the issue here.
    I was wrong in that it doesn't do this in 11.1. Same strange behavior shows up in both 11.1 and 11.2. And it looks like the problem is connected to adding secondary language (Korean in my case) in locale section during the installation. Here's what I tried.

    step1: Fresh installation of 11.2 on two separate machines and selected Korean as the secondary language in the locale section during the installation.

    step2: Both system displayed the strange behavior in renaming files.

    step3: On system A, I reinstalled 11.2 but without choosing secondary language. On system B, I deselected Korean as the secondary language in yast2, uninstalled scim and all related files, and uninstalled all korean related files. On both systems (A & B), now the dolphin file-dialogue behaves correctly as expected.

    So, this looks like a bug tied to the locale setting and KDE4.

    Any thought on how to address this from here?

    Thanks

    Woojin

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE4 file-dialogue behavior

    Check at kde in the bug list and report if necessary:
    https://bugs.kde.org/
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •