Results 1 to 7 of 7

Thread: OpenOffice and Klipper

  1. #1
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default OpenOffice and Klipper

    I've been having trouble with cut-and-paste in OOo 3.1.1, KDE 4.3.4, and found that disabling Klipper solves the problem. Has anyone else experienced this, and is Klipper actually needed for anything other than its fancy tricks (which I never use anyway)?
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: OpenOffice and Klipper

    Yes indeed I get this - it's a royal pain in the *ss
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: OpenOffice and Klipper

    And even i have this issue in Chromium as well in OOo3.1.1.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  4. #4
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: OpenOffice and Klipper

    I've done a bit of research on this and it seems that it's a well-known bug, OOo's not Klipper's, and has been reported. But given the relative importance of Linux compared to Windows for OOo, and the glacial speed at which OOo fixes bugs I'm not optimistic - in fact I'll rephrase that: at current rates of global warming, glaciers move a lot faster than OOo...
    I'll play around with the Klipper settings to see if there's a workaround.
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: OpenOffice and Klipper

    By accident I found that double clicking Ctrl-C in OO Calc appears to solve the problem. I've not encountered the problem in Writer.

  6. #6
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: OpenOffice and Klipper

    Quote Originally Posted by john_hudson View Post
    By accident I found that double clicking Ctrl-C in OO Calc appears to solve the problem. I've not encountered the problem in Writer.
    I have ONLY encountered it in Writer...
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  7. #7
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: OpenOffice and Klipper

    Changing the default Klipper configuration to "Synchronize contents of the clipboard and the selection" seems to make cut-and-paste in OOo behave as expected. Time will tell if it lasts.
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •