Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: KDESU not working on OpenSuse 11.2

  1. #11

    Default Re: KDESU not working on OpenSuse 11.2

    Quote Originally Posted by caf4926 View Post
    Works for me

    What output do you get in terminal when you do kdesu yast2
    I get no output at all...
    Since pressing enter (or clicking on ok) when the kdesu window appears does not have any effect, there is no output yet in the console...

    Do you think that reinstalling some packages will help someway? If so, which one?

  2. #12
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDESU not working on OpenSuse 11.2

    Please post result of this

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #13

    Default Re: KDESU not working on OpenSuse 11.2

    Quote Originally Posted by caf4926 View Post
    Works for me

    What output do you get in terminal when you do kdesu yast2
    I get no output at all, but in this case is pretty normal I think...
    Usually you get an output after you have clicked on ok or pressed enter whether the password you entered was correct or not.
    In my case, since both enter and click don't work, the console is still waiting for an input that can't see.

    Since it seems that I am the only one experiencing this problem, do you think that reinstalling some packages will help? If so, which one?

  4. #14

    Default Re: KDESU not working on OpenSuse 11.2

    Here it is:


    # | Alias | Nome | abilitato | Attualizza | Priorit | Tipo | URI | Servizio
    ---+----------------------+-----------------------+-----------+------------+----------+--------+---------------------------------------------------------------------------------+---------
    1 | Emulators | Emulators | S | S | 99 | rpm-md | Index of /repositories/Emulators/openSUSE_11.2 |
    2 | Google | Google | S | S | 99 | rpm-md | http://dl.google.com/linux/rpm/stable/i386 |
    3 | Java | Java | S | S | 99 | rpm-md | Index of /repositories/Java:/packages/openSUSE_11.2 |
    4 | KDE_Backports | KDE Backports | S | S | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.2 |
    5 | KDE_Community | KDE Community | S | S | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2 |
    6 | KDE_Contrib | KDE Contrib | S | S | 99 | rpm-md | Index of /repositories/openSUSE:/11.2:/Contrib/standard |
    7 | KDE_PlayGround | KDE PlayGround | S | S | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Playground/openSUSE_11.2 |
    8 | Libdvdcss repository | Libdvdcss repository | S | S | 99 | rpm-md | http://opensuse-guide.org/repo/11.2/ |
    9 | Mozilla | Mozilla | S | S | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.2 |
    10 | NVIDIA Repository | NVIDIA Repository | S | S | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.2/ |
    11 | OpenOffice | OpenOffice | S | S | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.2 |
    12 | Packman Repository | Packman Repository | S | S | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
    13 | VLC | VLC | S | S | 99 | rpm-md | Index of /pub/vlc/SuSE/11.2/ |
    14 | Wine | Wine | S | S | 99 | rpm-md | Index of /repositories/Emulators:/Wine/openSUSE_11.2 |
    15 | repo-debug | openSUSE-11.2-Debug | S | S | 99 | yast2 | Index of /debug/distribution/11.2/repo/oss |
    16 | repo-non-oss | openSUSE-11.2-Non-Oss | S | S | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
    17 | repo-oss | openSUSE-11.2-Oss | S | S | 99 | yast2 | Index of /distribution/11.2/repo/oss |
    18 | repo-source | openSUSE-11.2-Source | S | S | 99 | yast2 | Index of /source/distribution/11.2/repo/oss |
    19 | repo-update | openSUSE-11.2-Update | S | S | 99 | rpm-md | Index of /update/11.2

  5. #15
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDESU not working on OpenSuse 11.2

    There is a lot of stuff you don't need in that list if you want to make less trouble for yourself

    Remove
    4,6,7,8,13

    Then add this:
    Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2

    Then do this:
    http://public.bay.livefilestore.com/...itch%20kde.png

    You will need to follow this:
    Multi-media and Restricted Format Installation Guide - openSUSE Forums

    Doing this last
    http://public.bay.livefilestore.com/...er%20Final.png

    Logout and back in
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #16
    Kevin Miller NNTP User

    Default Re: KDESU not working on OpenSuse 11.2

    On 12/27/2009 10:46 AM, MadSplinter wrote:
    >
    > caf4926;2094176 Wrote:
    >> How else did you expect to do it?
    >>
    >> Are you saying using the launcher from the menu doesn't start yast.

    >
    > Let me try to explain better...
    > Let's say for simplicity that I want to start Yast (but again, it is
    > the same with every program that needs root privileges)
    >
    > Using su then launching yast, does work.
    >
    > Using kdesu yast, OR clicking on the yast icon, does NOT work, because
    > in both cases you are using the kdesu interface


    Have you messed with the /etc/sudoers file? If so, try using *your*
    password instead of the root password at the dialog prompt...

    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

  7. #17

    Default Re: KDESU not working on OpenSuse 11.2

    To the op,
    Does your machine running 24/7? I noticed it in this side, when not powering off my machine for a couple of days, sometimes kdesu stops working nor the yast icon from the kickoff menu when clicking it does nothing. When I restart the machine it works.

  8. #18

    Default Re: KDESU not working on OpenSuse 11.2

    To caf4926:
    I followed your procedure, but still having the same issue.

    To Kevin Miller:
    I did not configure the sudoers at all. Moreover, as I already said, putting in the correct password, the wrong one or no password at all does not make any difference.

    To joerione:
    The machine is a laptop, so it never stays on for long periods

  9. #19
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDESU not working on OpenSuse 11.2

    Very strange.. Not sure where you go from here
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #20

    Default Re: KDESU not working on OpenSuse 11.2

    I suppose I'll have to keep on using the console to start programs instead of kdesu... A bit annoying, but bearable anyway.

    By the way, thank you all very much for the suggestions

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •