Results 1 to 4 of 4

Thread: Can't install using zypper

  1. #1
    Join Date
    Oct 2009
    Location
    Dhaka,Bangladesh
    Posts
    251

    Default Can't install using zypper

    Code:
    sudo zypper in libavcodec52 libdvdnav4 libdvdread4 libffmpeg0 libquicktime0 libxine1 libxine1-codecs libxvidcore4 w32codec-all xvidcore                                            
    Loading repository data...                                                                          
    Reading installed packages...                                                                       
    'libavcodec52' is already installed.                                                                
    'libdvdnav4' is already installed.                                                                  
    'libdvdread4' is already installed.                                                                 
    'libxine1' is already installed.                                                                    
    'libxine1-codecs' is already installed.                                                             
    'libxvidcore4' is already installed.                                                                
    'w32codec-all' is already installed.                                                                
    Resolving package dependencies...                                                                   
    
    The following NEW packages are going to be installed:
      libavdevice52 libavformat52 libdc1394-22 libdv4 libffmpeg0 libquicktime0 libswscale0 xvidcore 
    
    8 new packages to install.
    Overall download size: 916.0 KiB. After the operation, additional 2.5 MiB will be used.
    Continue? [y/n/?] (y): y                                                               
    Retrieving package libdv4-1.0.0-146.3.i586 (1/8), 72.0 KiB (208.0 KiB unpacked)        
    Retrieving: libdv4-1.0.0-146.3.i586.rpm [done (12.7 KiB/s)]
    Installing: libdv4-1.0.0-146.3 [error]
    Installation of libdv4-1.0.0-146.3 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Provideversion index
    
    
    Abort, retry, ignore? [a/r/i] (a):

  2. #2

    Default Re: Can't install using zypper

    Did you try a 'zypper ref' then try installing again?

  3. #3
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Can't install using zypper

    I had this my friend, try rpm --rebuilddb Worked for me!! HTH..

    Rebuilding corrupted RPM database

    Repair an RPM database safely

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  4. #4

    Default Re: Can't install using zypper

    Thanks guys !
    rpm --rebuilddb worked for me as well
    Wasn't easy to find out

    Thanks a lot !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •