Results 1 to 3 of 3

Thread: Plasma Desktop crashes on startup

  1. #1
    galchen NNTP User

    Default Plasma Desktop crashes on startup

    I'm using openSUSE 11.2 for 2 months and never really had any trouble until yesterday. I installed valgrind and it didn't run, so in attempt to solve it i installed some other packages (glibc, qt something and some others, i cannot remember which, that people recommended. i think glibc-locale has solved it btw).

    anyways, when i start opensuse, i get a black screen and a an error alert saying that the plasma desktop has crashed. I can use alt+f2 to open any program. Only dekstop is not showing.

    The error details:
    Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
    [KCrash Handler]
    #5 0x00007f67e865e697 in Plasma::Wallpaper::setUsingRenderingCache(bool) () from /usr/lib64/
    #6 0x00007f67d49c4fa7 in ?? () from /usr/lib64/kde4/
    #7 0x00007f67e865e52d in Plasma::Wallpaper::restore(KConfigGroup const&) () from /usr/lib64/
    #8 0x00007f67e85946b3 in Plasma::Applet::paint(QPainter*, QStyleOptionGraphicsItem const*, QWidget*) () from /usr/lib64/
    #9 0x00007f67e689ac56 in ?? () from /usr/lib64/
    #10 0x00007f67e68a1fec in ?? () from /usr/lib64/
    #11 0x00007f67e68a4120 in ?? () from /usr/lib64/
    #12 0x00007f67e68a48f8 in ?? () from /usr/lib64/
    #13 0x00007f67e68a4ed9 in ?? () from /usr/lib64/
    #14 0x00007f67e68ce87c in QGraphicsView::paintEvent(QPaintEvent*) () from /usr/lib64/
    #15 0x00007f67e62d6501 in QWidget::event(QEvent*) () from /usr/lib64/
    #16 0x00007f67e668975b in QFrame::event(QEvent*) () from /usr/lib64/
    #17 0x00007f67e68c97eb in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib64/
    #18 0x00007f67e5b2ec38 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/
    #19 0x00007f67e627f43c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/
    #20 0x00007f67e6286baa in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/
    #21 0x00007f67e741716b in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/
    #22 0x00007f67e5b2f81c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/
    #23 0x00007f67e62de6f1 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/
    #24 0x00007f67e62df0a6 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) ()
    from /usr/lib64/
    #25 0x00007f67e62de1bb in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/
    #26 0x00007f67e649a129 in ?? () from /usr/lib64/
    #27 0x00007f67e649a43a in ?? () from /usr/lib64/
    #28 0x00007f67e62f933a in ?? () from /usr/lib64/
    #29 0x00007f67e6306fe3 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/
    #30 0x00007f67e63308ba in ?? () from /usr/lib64/
    #31 0x00007f67df244dde in g_main_context_dispatch () from /usr/lib64/
    #32 0x00007f67df2487a8 in ?? () from /usr/lib64/
    #33 0x00007f67df2488d0 in g_main_context_iteration () from /usr/lib64/
    #34 0x00007f67e5b5a1cc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/
    #35 0x00007f67e633044f in ?? () from /usr/lib64/
    #36 0x00007f67e5b2e0f2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/
    #37 0x00007f67e5b2e4cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/
    #38 0x00007f67e5b309f6 in QCoreApplication::exec() () from /usr/lib64/
    #39 0x00007f67e8d1cd6f in kdemain () from /usr/lib64/
    #40 0x00007f67e89a2a7d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>,
    rtld_fini=<value optimized out>, stack_end=0x7fff977ffa78) at libc-start.c:220
    #41 0x0000000000400699 in _start ()

    i think i somehow damaged with Qt lib.
    I've seen a similar post in a few places with a few suggestions that did not work for me. I tried remove the /.kde4 folder but it changes nothing.

    Any idea how i could get this fixed?

  2. #2
    Join Date
    Jun 2008
    The English Lake District. UK - GMT/BST
    Blog Entries

    Default Re: Plasma Desktop crashes on startup

    Undo what you did - that should solve it
    The install log is here: /var/log/zypp/history

    You can access that with a live cd like Parted Magic

    Then boot like this to Yast and remove the packages
    Level 3 Boot and Yast - Windows Live
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Plasma Desktop crashes on startup

    alt-f2 and run xterm and try plasma-desktop inside the xterm and look for the errors.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts