Results 1 to 2 of 2

Thread: Error to add a sound device in Xen full virtualization mode.

  1. #1
    mgtsai NNTP User

    Default Error to add a sound device in Xen full virtualization mode.

    I've installed openSUSE 11.2 and Xen 3.4.1 for dom0, and create a Windows XP domU virtual machine by YaST Virtual Machine Manager. Initially, no virtual sound card is attached in this domU, and the virtualized Window XP works fine. But after adding a sound card (i.e. ac97, or sb16), and starting this domU, a dialog pops up with the following error message:
    ****
    Error starting domain: POST operation failed: xend_post: error from xen daemon: (xend.err 'Domain unable to be unpaused: an integer is required')
    ****
    And after removing the virtual sound card, it works fine again.

    View xen's log (/usr/log/xen/qemu-dm-windowsxp.log.???), I've found an error message:

    /usr/lib/xen/bin/qemu-dm: invalid option -- '-soundhw'

    It seems that qemu-dm cannot recognize the option for assigning sound hardware: '-soundhw'

    Does anyone points the direction that how can I solve this problem without much technical operations (i.e. patch and re-compile Xen). Thanks a lot.

  2. #2

    Default Re: Error to add a sound device in Xen full virtualization m

    I don't have an answer for your problem, but you might have an answer for mine. I'm also running 11.2 and xen 3.4.1, and I've set up a full virtualization of windows xp - only in my case it hangs at "booting to hard disk..." when I try to run the xp vm. (I've got the windows xp in sda1, and linux in sda6.) Would you share the configuration you use for your xp vm?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •