Results 1 to 5 of 5

Thread: Clock gets changed every time i reboot the machine

  1. #1
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Clock gets changed every time i reboot the machine

    This is rather an annoying thing than a problem. I lately started to reboot the PC every night and noticed that my clock gets reset to Greenwich time -10(Toronto -5), like 2 times the settings are run. Now that I'm writing this i remember that i had some issues when the winter time kicked in, but not sure if I manually modified anything and more important where?
    I'm running KDE Version 4.3.4 (KDE 4.3.4) "release 2" on SuSe11.1(2.6.27.39-0.2-default). Any suggestions? I think I followed some instructions on a thread, because at the beginning there were some issue with time for some areas which kicked in earlier than in US.

  2. #2

    Default Re: Clock gets changed every time i reboot the machine

    I had similar problems. It seemed that even though I was connecting to NTP servers, it never actually reset the hardware clock time. After I did that, my problems went away.

    Cheers
    RM

  3. #3

    Default Re: Clock gets changed every time i reboot the machine

    For me, leaving the Hardware Clock Set to UTC box unchecked kept time from changing from the designated time zone after reboots.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,648

    Default Re: Clock gets changed every time i reboot the machine

    If you dual boot with windows. Windows assumes hardware clock is set to local time. Updates from time server reset clock to what it thinks is local time. Typically Unix based systems think the hardware is set to UTC. So there is a problem. Uncheck use UTC and that should work. If you multiboot Linuxes make sure all are set to the same standard.

  5. #5
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default Re: Clock gets changed every time i reboot the machine

    I'm having a similar issue
    Clock keeps reseting after reboot - openSUSE Forums
    I run a dual boot with windows. Something is just not right with my clock. After finding this post after I posted mine. I did the suggestions. I went into windows and fixed the clock issue. Restarted back to Linux. Unchecked UTC and the same issue still occurred. When I changed it back to UTC being checked it temporarily fixes it. I'm assuming it will be the wrong time after a reboot.
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •