Results 1 to 3 of 3

Thread: Compiz has stopped working

  1. #1

    Default Compiz has stopped working

    openSUSE 11.2. Compiz has stopped working for no apparent reason at some point indeterminate point in the last few days.
    If I try and enable desktop effects using simple-ccsm (Control Centre > Desktop Effects) then the following appears in the ~/.xsession-errors

    Code:
    which: no kwin in (/home/mike/bin:/usr/lib/mpi/gcc/openmpi/bin:/home/mike/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:/usr/NX/bin)
    which: no fusion-icon in (/home/mike/bin:/usr/lib/mpi/gcc/openmpi/bin:/home/mike/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:/usr/NX/bin)
    Checking for Xdmx: not present. 
    Checking for Xgl: not present. 
    xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log 
    Detected PCI ID for VGA: 01:00.0 0300: 10de:0295 (rev a1) (prog-if 00 [VGA controller])
    Checking for software rasterizer: not present. 
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Comparing resolution (1680x1050) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: present. 
    Checking for FBConfig: present. 
    Checking for Xgl: not present. 
    /usr/bin/compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
    /usr/bin/compiz (core) - Fatal: No manageable screens found on display
    Window manager warning: Failed to read saved session file /home/mike/.config/metacity/sessions/106352748a1c734325126147670826846200000048160025.ms: Failed to open file '/home/mike/.config/metacity/sessions/106352748a1c734325126147670826846200000048160025.ms': No such file or directory
    which: no kwin in (/home/mike/bin:/usr/lib/mpi/gcc/openmpi/bin:/home/mike/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:/usr/NX/bin)
    which: no fusion-icon in (/home/mike/bin:/usr/lib/mpi/gcc/openmpi/bin:/home/mike/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:/usr/NX/bin)
    Checking for Xdmx: not present. 
    Checking for Xgl: not present. 
    xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log 
    Detected PCI ID for VGA: 01:00.0 0300: 10de:0295 (rev a1) (prog-if 00 [VGA controller])
    Checking for software rasterizer: not present. 
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Comparing resolution (1680x1050) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: present. 
    Checking for FBConfig: present. 
    Checking for Xgl: not present. 
    /usr/bin/compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
    /usr/bin/compiz (core) - Fatal: No manageable screens found on display
    Anyone else seen this and/or know a solution?

  2. #2
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Compiz has stopped working

    Hi,

    It looks like, from those logs, that you're using an Nvidia card. Have you tried installing the proprietary drivers? Also which desktop environment are you using, and where did you install compiz from?

    Just to make sure you have the right packages could you please open a terminal and provide the output of:

    Code:
    rpm -qa --last "*compiz*"
    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  3. #3

    Default Re: Compiz has stopped working

    I have the proprietary Nvidia driver installed. Using GNOME (too much time on Ubuntu and SLED - forget that openSUSE doesn't have a default DE. Oh except it does now doesn't it, KDE. Anyway...)

    I've fixed the problem though it's one of those fixes where I don't know what fixed it. I deleted the contents of ~/.config/compiz, that didn't help. So I uninstalled compiz compiz-gnome compiz-manager compizconfig-settings-manager compiz-branding-openSUSE and then re-installed them. Now enabling Desktop Effects works again.



    Didn't know about the --last option on rpm, that will be useful in future. The output regarding compiz is irrelevant in this case since the last install time was last night before I saw your reply.

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •