Results 1 to 9 of 9

Thread: Black Screen with TightVNC

  1. #1

    Default Black Screen with TightVNC

    A recent OpenSuse 11.2 update is causing one to view a black screen with an X in the Tight VNC window of the remote machine when connecting with VNC Viewer (i.e. vncviewer IPAddress:1 ) in a console.

    I have two OpenSuse11.2 machines (one with no updates since 11/2009) and one I updated this week (12/16/2009). I am able to successfully use Tight VNC to connect to the OpenSuse11.2 machine without recent updates but get a black screen when attemmpting to connect to a recently updated OpenSuse 11.2 machine.

    My source machine is also a OpenSuse11.2 desktop with current updates.

    Please advise.

    -Mike
    Suse Linux Enterprise Server 11
    Suse Linux Enterprise Server 10 - SP2
    OpenSuse 11.1, KDE 4.1.3
    OpenSuse 11.1, KDE 4.2

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Black Screen with TightVNC

    There are four ways that I know to run VNC in Linux, so let's narrow the field a bit: On the updated machine, which method are you using to run TightVNC (like, how do you switch it on and any other info you like to supply that might help us with that question).
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  3. #3

    Default Re: Black Screen with TightVNC

    xlinux4lifex, please have a look at my recent post under 'VNC is not working' for a possible solution.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,490
    Blog Entries
    37

    Default Re: Black Screen with TightVNC

    Quote Originally Posted by plodder View Post
    xlinux4lifex, please have a look at my recent post under 'VNC is not working' for a possible solution.
    xlinunx4lifex, take a look at post#62 (by plodder) here in this thread: VNC is not working - Page 2 - openSUSE Forums

  5. #5

    Default Re: Black Screen with TightVNC

    Guys,

    Thanks for the links. I will check them out.

    The method I use for TightVNC has always been from a console on the source machine. I will type "vncviewer IPADDRESS:1" and then I am connected to the target machine.

    This has always worked for me since OpenSuse 10.3. But suddenly after recent 11.2 updates, I just get a black screen on the updated target machine. The other machine that I did not update, I can still VNC into it via the command line with no trouble.

    -Mike
    Suse Linux Enterprise Server 11
    Suse Linux Enterprise Server 10 - SP2
    OpenSuse 11.1, KDE 4.1.3
    OpenSuse 11.1, KDE 4.2

  6. #6

    Default Re: Black Screen with TightVNC

    While the link to the other thread is helpful, that thread has long since devolved into a flamethrowing mess...

    The fix for "Black screen when trying to VNC to a openSuSE 11.2 box" (with ANY native VNC viewer) is the IPv6 setting...

    Turn off IPv6 and VNC connects like buttah...

  7. #7
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    298

    Default Re: Black Screen with TightVNC

    Quote Originally Posted by uberkind View Post
    Turn off IPv6 and VNC connects like buttah...
    I turned off IPv6 on both server and client, in Yast/NetworkDevices/NetworkSettings. There is no place visible to me to configure IPv6 in LinuxVNC server or the client krdc. But I still get a black screen on the client side (openSuse 11.1).

    Of possible relevance: on the server (oS 11.2) LinuxVNC shows up in the Process Table of the System Monitor, but is not listed in Yast/System/SystemServices (runlevel). The latter is where I usually configure daemons to start on bootup. I expected the vnc server daemon to be there after enabling the vnc network service in Yast.

    Any thoughts?
    Thanks

  8. #8
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    298

    Thumbs up Re: Black Screen with TightVNC

    Got VNC working from the tutorial at KDE
    Tutorials/Access another computer's display - KDE UserBase

    Note that for me, on a LAN, the "user-desktop" of the remote machine is the host name of that machine. Had to restart the ssh daemon (sshd) on the server in Yast/system/System Services (run level) before connecting from the client notebook.

  9. #9
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    298

    Default Re: Black Screen with TightVNC

    Also, the server host name is configured in the "hosts" file of the client machine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •