Results 1 to 8 of 8

Thread: No Mail From Cron In 11.1

  1. #1

    Default No Mail From Cron In 11.1

    Hello

    When I run cronjobs, I don't receive an email despite having one sent to me from the cronjob. I can look in mailq and see this output:

    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    16FD42C2FA 587 Thu Dec 17 00:30:01 root@linux-m8o2.site
    (connect to idcmail-mx1so.cg.shawcable.net[24.71.223.11]:25: Connection timed out)
    robharper2@shaw.ca

    58FFE2C2C1 581 Tue Dec 15 00:00:01 root@linux-m8o2.site
    (connect to idcmail-mx1so.cg.shawcable.net[24.71.223.11]:25: Connection timed out)
    robharper2@shaw.ca

    C33AA2C305 576 Fri Dec 18 00:30:01 root@linux-m8o2.site
    (connect to idcmail-mx2no.cg.shawcable.net[64.59.134.8]:25: Connection timed out)
    robharper2@shaw.ca

    A2C0E2C304 575 Fri Dec 18 00:00:01 root@linux-m8o2.site
    (connect to idcmail-mx2no.cg.shawcable.net[64.59.134.8]:25: Connection timed out)
    robharper2@shaw.ca

    709602C2E0 583 Tue Dec 15 00:30:01 root@linux-m8o2.site
    (connect to idcmail-mx2no.cg.shawcable.net[64.59.134.8]:25: Connection timed out)
    robharper2@shaw.ca

    F26572C2F9 585 Thu Dec 17 00:00:01 root@linux-m8o2.site
    (connect to idcmail-mx2no.cg.shawcable.net[64.59.134.8]:25: Connection timed out)
    robharper2@shaw.ca

    -- 4 Kbytes in 6 Requests.
    robert@linux-m8o2:~>

    I have looked in some other posts and see similar questions, but I need very specific instructions on how to fix this. Could someone please help me out?

    Thanks
    Harpo2

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: No Mail From Cron In 11.1

    Probably because your ISP blocks customer computers from sending out mail directly on port 25 because infected machines send out spam. You have to relay through your ISP's relayhost. When you find out what it is, you can set it in the postfix config, restart postfix and you can mail out.

  3. #3

    Default Re: No Mail From Cron In 11.1

    Perfect, I will do that. Errrr, where do I get that

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: No Mail From Cron In 11.1

    Get what, the relayhost? Ask your ISP. It's usually the mail server that they ask you do connect to to fetch and send your mail.

  5. #5

    Default Re: No Mail From Cron In 11.1

    Is that not the relay host that I have listed in my output from mailq? I am on hold with my ISP now, but thought I would check on that while waiting.

  6. #6

    Default Re: No Mail From Cron In 11.1

    Okay, mail servers are "shawmail.wp.shawcable.net". Where do I place this in postfix? Please point me in the right direction with detail where possible.

    Thanks

  7. #7
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: No Mail From Cron In 11.1

    Well I only use the CLI, not YaST to configure postfix, so if you are not scared of using a text editor...

    Code:
    as root of course, edit /etc/sysconfig/postfix and set RELAYHOST.
    SuSEconfig --module postfix
    rcpostfix reload
    I'm sure you can do this in YaST, but I never bothered to find out how, it was always faster for me this way, and doesn't break YaST configuration either. This assumes you have not modified main.cf yourself.

  8. #8

    Default Re: No Mail From Cron In 11.1

    Outstanding! Problem solved. Thanks for all the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •