Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: gnome-panel gone under 11.1

  1. #1
    Join Date
    Jul 2008
    Location
    Colorado
    Posts
    22

    Default gnome-panel gone under 11.1

    Yesterday all good. Today I login in and I get little task windows that when I enlarge them are blank but have a title bar of "slab". I think those are somehow connected to the gnome-panel which is now gone from my desktop. I finally killed the respawning slab tasks with
    Code:
    :~>metacity | gnome-panel
    Upon a reboot (no panel so I could logout) I have no spawning "slab" tasks but I have no gnome-panel either. when I try this
    Code:
    :~> gnome-panel
    gnome-panel: symbol lookup error: /usr/lib/libsoup-2.4.so.1: undefined symbol: g_resolver_get_default
    Everything is up to date. Any suggestions?

  2. #2
    Join Date
    Jul 2008
    Location
    Colorado
    Posts
    22

    Default Re: gnome-panel gone under 11.1

    A little more info:

    libsoup-2.4.so.1 is apparently version 2.29.3-47.2 installed on Dec. 11, 2009. Must have been installed with some other upgrade. I suppose I could downgrade but the notes imply an awful lot of good stuff has been fixed. I'll wait for some guidance.

  3. #3
    Join Date
    Jul 2008
    Location
    Colorado
    Posts
    22

    Default Re: gnome-panel gone under 11.1

    Nobody has seen this? It's not like I'm running Gentoo and hand building this stuff, in which case I would have only myself to blame. This was pushed out with some other package, maybe the Mono or MonoDevelop stuff. Now, if I back this libsoup library out I get the lovely task of finding out what I just hobbled or broke.

  4. #4

    Default Re: gnome-panel gone under 11.1

    i got this too on 2 seperate builds...
    i'm really fed up with this opensuse gnome rubbish...with all the desktop, xine not playing video etc etc & pulse sound issues if these developers aren't going to provide a workable desktop gui i will be moving to fedora!!!!!!!!!

    anyone know how to troubleshoot this problem before i help this opensuse out the 4th floor window never to return ?!!?


    Thanks

  5. #5
    Join Date
    Jul 2008
    Location
    Colorado
    Posts
    22

    Default Re: gnome-panel gone under 11.1

    Thanks for the info jagreen. Yeah, this cost me 4 hours of chasing around Friday still with no solution. This is basic functionality and yes I do know that this work is all given freely to the community. On the other hand I have used openSuse to demonstrate to business with the statement that the SUSE product would be just like what I was demoing but with support. This type of demo wouldn't help - openSuse is a gateway product for Novell to real paid for products.

  6. #6

    Default Re: gnome-panel gone under 11.1

    Sorry to make a rant also. I've been lurking this forum for a while before deciding to register and I am a bit tired of those first posts with threatening behavior, we don't need to threaten this people we are just volunteers here willing to answer if we have an idea of the issue. If you find the distro to be flaky then find one suited for you else if have time to tinker give the time to troubleshoot by research. My apology.

    Back to topic.
    Try this command, I am not sure if this will work.
    Code:
    gconftool-2 --recursive-unset /apps/panel

  7. #7
    Join Date
    Jul 2008
    Location
    Colorado
    Posts
    22

    Default Re: gnome-panel gone under 11.1

    Thanks joerione that seems to have worked. Maybe it was on the gnome site under gnome panel but I sure couldn't find it. I'm curious to know how the gconftool-2 rebuilt libsoup so that the undefined symbol: g_resolver_get_default is now present. Don't you have to relink libraries to fix the symbol table?

  8. #8

    Default Re: gnome-panel gone under 11.1

    Quote Originally Posted by joerione View Post
    Sorry to make a rant also. I've been lurking this forum for a while before deciding to register and I am a bit tired of those first posts with threatening behavior, we don't need to threaten this people we are just volunteers here willing to answer if we have an idea of the issue. If you find the distro to be flaky then find one suited for you else if have time to tinker give the time to troubleshoot by research. My apology.

    Back to topic.
    Try this command, I am not sure if this will work.
    Code:
    gconftool-2 --recursive-unset /apps/panel
    ..don't know what the above is supposed to do or result in -is the panel suppose to appear...?

  9. #9
    Join Date
    Jul 2008
    Location
    Colorado
    Posts
    22

    Default Re: gnome-panel gone under 11.1

    Try rebooting. I know without a panel you can't just logout, nor could I go to root console via Ctrl-Alt-F2 and "logout jack" so I just rebooted from the root console and upon coming back the panel appeared. Thanks again joerione.

  10. #10

    Default Re: gnome-panel gone under 11.1

    doesnt do anything for me

    i reinstalled all the gnome panel type modules i could see previously to try and fix this =no use
    surely reinstall of the gnome modules would do it ?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •