Results 1 to 6 of 6

Thread: postfix + sasl + postgres

  1. #1

    Default postfix + sasl + postgres

    Hi,

    I customise authentification in postfix through sasl + postgres

    smtpd.conf:

    pwcheck_method: auxprop
    auxprop_plugin: sql
    sql_engine: pgsql
    mech_list: PLAIN LOGIN
    sql_hostnames: localhost
    sql_user: ******
    sql_passwd: ******
    sql_database: ******
    sql_verbose: yes
    sql_select: SELECT passwd FROM t_users WHERE userid = ' %u ';

    In log writes:

    postfix/smtpd [10884]: unable to dlopen/usr/lib64/sasl2/libsql.so:/usr/lib64/sasl2/libsql.so: undefined symbol: mysql_field_count

    The package cyrus-sasl-sqlauxprop is installed.

    Prompt in what a problem?

  2. #2

    Default Re: postfix + sasl + postgres

    There is no need to use auxprop_plugin. Try this one:

    pwdcheck_method: auxprop
    sql_engine: pgsql
    sql_user: ******
    sql_passwd: ********
    sql_hostnames: localhost
    sql_database: ******
    sql_select: SELECT passwd FROM t_users WHERE userid = ' %u '
    mech_list: login plain
    log_level: 10

    Be sure to have installed PostgreSQL support for sasl.

    BTW, consider using userid='%u@%r' in sql_select if needed.

    Best regards.

  3. #3

    Default Re: postfix + sasl + postgres

    log_level: 10

    no effect? in logs only one string


    postgresql is installed ok and work with postfix and dbmail.
    Don't work only sasl

    And at what here mysql_field_count if I set parametre pgsql? O_o

  4. #4

    Default Re: postfix + sasl + postgres

    Quote Originally Posted by akitos View Post

    log_level: 10

    no effect? in logs only one string
    sorry
    this true:

    log_level: 10

    no effect
    in logs only one string

  5. #5

    Default Re: postfix + sasl + postgres

    Quote Originally Posted by akitos View Post
    postfix/smtpd [10884]: unable to dlopen/usr/lib64/sasl2/libsql.so:/usr/lib64/sasl2/libsql.so: undefined symbol: mysql_field_count
    Please, trace some bug tracks for solution:
    https://bugzilla.novell.com/show_bug.cgi?id=555568

    Try to update your software, cause fix is already avail for 11.2, afaik. If you're using only main OSS repo, give a try to this repo (as mentioned in bugtrack comments).

    P.S. Next time, please provide OS version and repository names, from where you've installed packages.

  6. #6

    Default Re: postfix + sasl + postgres

    Thanks,

    And why the main is not refreshed repository? The matter is that I support it a server and if I will make that that not standardly who that of another can have problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •