Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: kde4 desktop view right mouse dont work

  1. #1

    Default kde4 desktop view right mouse dont work

    suse 11.1 and kde4
    on the desktop right mouse doesnt' show the contestual menu
    on the icons yes
    on another desktop/activity with dashboard yes
    is a bug or my error??

  2. #2
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: kde4 desktop view right mouse dont work

    Hi,

    What version of KDE4 are you using?

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  3. #3

    Default Re: kde4 desktop view right mouse dont work

    4.3 or later (how can I check? in 3.5 opening the k menu was shown there)

  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: kde4 desktop view right mouse dont work

    If you click the application launcher (the kmenu) then go to Computer, then system information, it will tell you what version of KDE you're using.

    Could you also please open a terminal and provide the output of:

    Code:
    zypper lr -d
    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5

    Default Re: kde4 desktop view right mouse dont work

    KDE 4.3.80(KDE 4.4 beta1)release 197



    pla@linux-eq93:~> zypper lr d
    # | Alias | Nome | abilitato | Attualizza
    ---+-----------------------------+-----------------------------+-----------+-----------
    1 | Drivers_per_webcams_11.1 | Drivers per webcams 11.1 | S | S
    2 | GNOME_2.28_stable | GNOME 2.28 stable | S | S
    3 | KDE3 | KDE3 | S | S
    4 | KDE4_community | KDE4 community | S | S
    5 | KDE4_factory | KDE4 factory | S | S
    6 | KDE4_stable | KDE4 stable | S | S
    7 | KDE:Backports_11.1 | KDE:Backports 11.1 | S | S
    8 | Kernel_HEAD | Kernel HEAD | S | S
    9 | Kernel_next-linux | Kernel next-linux | No | S
    10 | OpenOffice.org_11.1 | OpenOffice.org 11.1 | S | S
    11 | Versioni_CVS_di_Wine_11.1 | Versioni CVS di Wine 11.1 | S | S
    12 | XFCE_11.1 | XFCE 11.1 | S | S
    13 | _X11:Compiz_11.1 | X11:Compiz 11.1 | No | S
    14 | agg | agg | S | S
    15 | anubis_(msn_last_version) | anubis (msn last version) | S | S
    16 | contrib_factorry_11.1 | contrib factorry 11.1 | S | S
    17 | coolmax_(blueman) | coolmax (blueman) | S | S
    18 | devel:languageserl | devel:languageserl | S | S
    19 | devel:tools:building | devel:tools:building | S | S
    20 | dstoecker-11.1(ksynaptics) | dstoecker-11.1(ksynaptics) | S | S
    21 | google-chrome | google-chrome | S | S
    22 | home:etrash:webapps | home:etrash:webapps | S | S
    23 | jhaygood-contrib-(chromium) | jhaygood-contrib-(chromium) | S | S
    24 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No
    25 | openSUSE:11.1:NonFree | openSUSE:11.1:NonFree | S | S
    26 | repo | NVIDIA 11.1 | S | S
    27 | repo-debug | Debug 11.1 | S | S
    28 | repo-non-oss | Non-Oss 11.1 | S | S
    29 | repo-oss | Oss 11.1 | S | S
    30 | repo-source | Source 11.1 | S | S
    31 | repo-update | Update 11.1 | S | S
    32 | repo_10 | Packman | S | S
    33 | repo_11 | Education 11.1 | S | S
    34 | repo_7 | Giochi 11.1 | S | S
    35 | repo_8 | Mozilla 11.1 | S | S
    36 | repo_9 | VideoLan | S | S
    37 | serverhp:applications | serverhp:applications | S | S
    pla@linux-eq93:~>

  6. #6
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: kde4 desktop view right mouse dont work

    Wow, that's a lot of repositories.

    Anyways, since you're using the beta (which really isn't recommended) I'm guessing you're losing the ability to right click during the search containment. I too have found the folly of this containment's inability to right click. By default it doesn't have any mouse input actions.

    So, all you have to do is when you're on the desktop that doesn't let you right click, hit alt+d then alt+s in quick succession and that will open up the search containment settings. Go to mouse and add an input (which would be right clicking) and it should automatically put the contextual menu in there. You can also set it to application launcher or switch desktops, etc.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,590

    Default Re: kde4 desktop view right mouse dont work

    If you are pulling things from the Factory you can get all sorts of odd behavior. I'd disable at lest Factory and only use it if I really needed it. Things on the factory floor may not yet be ready to ship.

  8. #8
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: kde4 desktop view right mouse dont work

    Quote Originally Posted by pier_andreit View Post
    KDE 4.3.80(KDE 4.4 beta1)release 197



    pla@linux-eq93:~> zypper lr d
    # | Alias | Nome | abilitato | Attualizza
    ---+-----------------------------+-----------------------------+-----------+-----------
    1 | Drivers_per_webcams_11.1 | Drivers per webcams 11.1 | S | S
    2 | GNOME_2.28_stable | GNOME 2.28 stable | S | S
    3 | KDE3 | KDE3 | S | S
    4 | KDE4_community | KDE4 community | S | S
    5 | KDE4_factory | KDE4 factory | S | S
    6 | KDE4_stable | KDE4 stable | S | S
    7 | KDE:Backports_11.1 | KDE:Backports 11.1 | S | S
    8 | Kernel_HEAD | Kernel HEAD | S | S
    9 | Kernel_next-linux | Kernel next-linux | No | S
    10 | OpenOffice.org_11.1 | OpenOffice.org 11.1 | S | S
    11 | Versioni_CVS_di_Wine_11.1 | Versioni CVS di Wine 11.1 | S | S
    12 | XFCE_11.1 | XFCE 11.1 | S | S
    13 | _X11:Compiz_11.1 | X11:Compiz 11.1 | No | S
    14 | agg | agg | S | S
    15 | anubis_(msn_last_version) | anubis (msn last version) | S | S
    16 | contrib_factorry_11.1 | contrib factorry 11.1 | S | S
    17 | coolmax_(blueman) | coolmax (blueman) | S | S
    18 | devel:languageserl | devel:languageserl | S | S
    19 | devel:tools:building | devel:tools:building | S | S
    20 | dstoecker-11.1(ksynaptics) | dstoecker-11.1(ksynaptics) | S | S
    21 | google-chrome | google-chrome | S | S
    22 | home:etrash:webapps | home:etrash:webapps | S | S
    23 | jhaygood-contrib-(chromium) | jhaygood-contrib-(chromium) | S | S
    24 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No
    25 | openSUSE:11.1:NonFree | openSUSE:11.1:NonFree | S | S
    26 | repo | NVIDIA 11.1 | S | S
    27 | repo-debug | Debug 11.1 | S | S
    28 | repo-non-oss | Non-Oss 11.1 | S | S
    29 | repo-oss | Oss 11.1 | S | S
    30 | repo-source | Source 11.1 | S | S
    31 | repo-update | Update 11.1 | S | S
    32 | repo_10 | Packman | S | S
    33 | repo_11 | Education 11.1 | S | S
    34 | repo_7 | Giochi 11.1 | S | S
    35 | repo_8 | Mozilla 11.1 | S | S
    36 | repo_9 | VideoLan | S | S
    37 | serverhp:applications | serverhp:applications | S | S
    pla@linux-eq93:~>
    You also forgot to add the -d to zypper lr when you typed it into the command line. It should have given the url's for your repositories as well. I already see you're mixing both stable and KDE repositories which is a recipe for disaster. Please change them accordingly with Yast>Software Repositories.

    Code:
    6  | KDE4_stable                 | KDE4 stable                 | No        | No
    If you want to continue using factory which is NOT recommended unless you know what you're doing or are trying to crush bugs for the new KDE.

    Code:
    5  | KDE4_factory                | KDE4 factory                | No        | No
    if you want a stable KDE which is HIGHLY recommended. You'll have to go through some conflicts to switch back to stable. For any conflicts that come up, check the option to downgrade.

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  9. #9

    Default Re: kde4 desktop view right mouse dont work

    Quote Originally Posted by ijbreakey View Post
    Wow, that's a lot of repositories.
    yes I have to disable some of them :-) is the effect of one click install too

    Quote Originally Posted by ijbreakey View Post
    Anyways, since you're using the beta (which really isn't recommended)
    I know but experiments the most of the times go well :-)
    Quote Originally Posted by ijbreakey View Post
    I'm guessing you're losing the ability to right click during the search containment. I too have found the folly of this containment's inability to right click. By default it doesn't have any mouse input actions.

    So, all you have to do is when you're on the desktop that doesn't let you right click, hit alt+d then alt+s in quick succession and that will open up the search containment settings. Go to mouse and add an input (which would be right clicking) and it should automatically put the contextual menu in there. You can also set it to application launcher or switch desktops, etc.
    I tried before, it doesn't work and also I lost the possibility to have one activity for desktop!!!
    Quote Originally Posted by ijbreakey View Post

    Take Care,

    Ian
    You too :-)

  10. #10
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: kde4 desktop view right mouse dont work

    Alright, so as long as I know you're experimenting, just let it be known that anything that may go wrong, is probably because you're trying out beta software.

    I would suggest creating a new user on your system and seeing if that account experiences the same problems.

    When you hit alt+d then alt+s make sure to do it quickly. Also, to help, trying hitting the alt key then d key, then alt key then s key in rapid succession when you do this.

    *Edit: Also, for the having more than one activity, open up Configure Desktop (Personal Settings) and then go to Desktop. Click on Multiple Desktops and uncheck Different activity for each Desktop.

    Take Care,

    Ian
    Last edited by ijbreakey; 18-Dec-2009 at 12:33. Reason: Added more information
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •