Results 1 to 6 of 6

Thread: Error in titlebar

  1. #1

    Default Error in titlebar

    Hi everyone! First post here, so if i'm doing something wrong or posting in the wrong place, please forgive me

    I'm using OpenSUSE 11.2 with KDE 4.3.4
    window decoration is nitrogen, but i had the same problem with oxygen as well.



    I see this a lot, especially when the window title changes, like when i'm surfing the internet. It's really starting to annoy me and i'm wondering, has it got something to do with my nvidia drivers or is it a bug in the KDE window decoration? I searched if somebody else got the same bug but i couldn't find anything about it.

    Thanks

  2. #2
    Join Date
    Nov 2009
    Location
    Maryland, USA
    Posts
    43

    Default Re: Error in titlebar

    I, and probably others, can't tell for sure what the problem is that you're asking for help to solve. Can you add a few words to describe what's wrong with the picture you sent? In this case, I'm not sure that your picture is worth a thousand words. Not the right words, anyway.

    Have you tried different desktop/window effects settings, starting with none and adding to see if it's a particular effect that causes the problem? Different text sizes? Does it happen in all applications or typically just one? Which one?

  3. #3

    Default Re: Error in titlebar

    Allright, i'll try to put it in words. In every application that changes the window title, for example when you surf the net in a browser, when you change directories in dolphin..., the title doesn't change smoothly. Half of the time it stays unreadable for a few seconds (like you can see in the screenshot) before it changes.

    I tried changing all kinds of window decoration options, that didn't have any effect. I didn't disable any desktop effects, so that's what i did now:

    Turning off wobbly windows reduces the bug you see in the picture. With wobbly windows disabled it looks better. It sometimes still takes a couple of seconds to change the window title but at least it stays readable. When i disable all desktop effects the title seems to change correctly without delay.

    So i'm assuming it has something to do with my nvidia driver (and it can't be solved without a new driver?) My driver version is nvidia 190.42.

  4. #4

    Default Re: Error in titlebar

    update: even with wobbly windows disabled, i still have the unreadable title text, although less. The only way to solve the problem entirely is to disable all desktop effects.

  5. #5
    Join Date
    Nov 2009
    Location
    Voorhout, Netherlands
    Posts
    21

    Default Re: Error in titlebar

    maybe if you change the titlebar decoration? It might be something specific with that. Oh, I just saw you tried that..maybe a different decorator then? You use KDE compositing? I use Compiz with the emerald decorator and it is smooth.

  6. #6

    Default Re: Error in titlebar

    It hasn't occurred yet with the window decoration "Ozone" (and i think that's the one that openSUSE uses as default) maybe that's why a lot of people here haven't seen it. But if this is the case i wonder why it hasn't been noticed before with the other window decorations... Or perhaps it's just a combination of things, i don't know. I tried other window decoration engines, but not long enough to see if the bug's there or not. I'd like to stick to KWin since it's well integrated into KDE, so i won't try compiz just to get the window title working as it should.

    Anyway, i'll use Ozone for now, but i'll miss the options i had with Nitrogen to customize the theme to my liking. If anyone had a similar problem and found the cause of it, please let me know!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •