Results 1 to 6 of 6

Thread: SUSE 11.2 VNC server does not work

  1. #1
    Join Date
    Sep 2008
    Location
    Sydney, Aus
    Posts
    29

    Unhappy SUSE 11.2 VNC server does not work

    Hello,

    I've just installed 11.2 on a couple of machines. I cannot get VNC to work. It does not even work betwen the two 11.2 machines!! VNC opens, but the screen is black. This is serious because one is supposed to be a headless server, but I can't do that without VNC (or something similar). How can it be that VNC does not even work between two installations of the same version?? It was working fine when they were SuSE 10.3. I have checked these forums, and I've tried playing with the colour depth, but nothing works.

    Thanks ...

  2. #2

    Default Re: SUSE 11.2 VNC server does not work

    VNC is a problematic software. It rarely works as advertised.

    If you want, I can tell you how to run a server+client combination that might work.

    The server is x11vnc, the client is ssvnc.

    These are not opensuse's native programs.

  3. #3
    Join Date
    Sep 2008
    Location
    Sydney, Aus
    Posts
    29

    Default Re: SUSE 11.2 VNC server does not work



    Further research led me back to these forums:

    OpenSuse 11.1 - Vnc black/white with X cursor - openSUSE Forums

    This worked (removing the IPv6 line from the HostNames list)

  4. #4
    Join Date
    Dec 2009
    Location
    Thailand
    Posts
    60

    Default Re: SUSE 11.2 VNC server does not work

    Thank you, I will try.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: SUSE 11.2 VNC server does not work

    Some other solutions ...

    The suggested fix from post#62 in this thread: VNC is not working - Page 2 - openSUSE Forums

    Or alternatively install x11vnc and tightvnc, open up your firewall port#22 and port#5900 and try the approach in post #4 from this thread: VNC is not working - openSUSE Forums

  6. #6
    Join Date
    Sep 2008
    Location
    Sydney, Aus
    Posts
    29

    Default Re: SUSE 11.2 VNC server does not work

    Thanks oldcpu. I like the look of the fix from post#62 - it actually explains what is wrong and why the fix should work. I will try it, and report back! (I was a little concerned at removing a line from /etc/hosts without really knowing what I was doing).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •