Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: 11.2, X not starting

  1. #1

    Default 11.2, X not starting

    Hi all,

    After upgrading from 11.1 to 11.2 X no longer starts upon boot. If I login as root I can simply type "gdm" which kicks off the auto login and Gnome starts up. Everything works fine after that (in fact, things are running much faster and wi-fi, which was previously buggy for me, is no longer any problem at all!)

    Anyway, is there something in my configuration that is preventing the window manager from starting automagically?

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: 11.2, X not starting

    Don't login as root.
    Did you try login as user?

    Disable auto login via Yast.
    Disable Auto-Login - openSUSE Forums

    Can you get to a user login with UI or just CLI?
    What happens at CLI if you do startx
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: 11.2, X not starting

    If I login as user and try startx I get:
    xinit: no such file or directory (errno 2)
    no server "/usr/bin/X.x11-video-fglrxG01 in PATH

    If I login as root and try startx I get:
    /root/.xserverrc: line 51: exec: X: not found
    unable to connect to X server

    BTW, I have seen a lot of use of the terms UI and CLI but have no idea what they mean...

    I'll try disabling the autologin in YAST. One thing I notice is that after I start the window manager (as root) using "gdm" I do see the autologin screen show up (very briefly) at which point the window manager starts and things run fine...

    Thanks for your help!

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: 11.2, X not starting

    What graphics device do you have?

    You should be able to disable auto login by going to Yast this way:
    Boot to Level 3, then Yast and More.... - openSUSE Forums
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: 11.2, X not starting

    Quickie update...

    I disabled auto-login, but still need to execute the manual "gdm" window manager start-up. Now, however, I get the login screen rather than the auto-login.

    But, I was trying to figure out how to disable the auto-login next, so that was useful feedback for that purpose anyway... :-)

    thanks

  6. #6

    Default Re: 11.2, X not starting

    Oh, and graphics is ATI Radeon xpress 200M

    I'm using the Radeon driver -- was previously using the ATI driver on 11.1, but could not get sax2 to work with fglrx. Perhaps I needed to try fglrxG01? But, anyway, the Radeon driver seems to be working MUCH better as some 3D games that were not working on 11.1 are now working on 11.2... Well, okay, maybe it's not the driver, but I'm guessing that it is based on some other info gleaned from the forums...

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: 11.2, X not starting

    My knowledge on ATI is not good because I have never had ATI. But I can tell you there have been major issues recently with ATI not providing drivers. But you should not and neither should you need to login as root to get a display.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: 11.2, X not starting

    Okay, I made perhaps a little progress...

    YAST - edit /etc/sysconfig: changed DISPLAYMANAGER from xorg-fglrxG01 to xorg

    It still did not auto-start the display manager, however, I can now login as user and execute startx which starts the default wm (gdm in this case).

    So, maybe I'm one step closer?

  9. #9

    Unhappy Re: 11.2, X not starting

    Oops, one step forward, two steps back...

    I went back into /etc/sysconfig and changed the displaymanager to xdm. On the next boot I got a black screen and no response to any input. So, I booted failsafe, changed this back to gdm, but now I still have the same problem, black screen.

    I reran sax2, just to make sure that wasn't the issue, and no change. I can now only boot in "failsafe" mode -- all other attempts to boot in the normal mode result in black screen with no response...

    help?

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,721
    Blog Entries
    20

    Default Re: 11.2, X not starting

    I suggest a careful look at this
    ATI/Troubleshooting - openSUSE
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •