Results 1 to 9 of 9

Thread: Package refuses to uninstall

  1. #1
    Join Date
    Nov 2009
    Location
    Dallas, Texas, USA
    Posts
    55

    Default Package refuses to uninstall

    Hi,

    I'm a bit new to openSUSE and I'm more comfortable with Ubuntu's package management. That said, I'm having trouble removing an RPM. I'm trying to remove uShare and it's being stubborn.

    Code:
    zypper rm ushare                  
    Loading repository data...                                 
    Reading installed packages...                              
    Resolving package dependencies...                          
    
    The following package is going to be REMOVED:
      ushare                                     
    
    1 package to remove.
    After the operation, 123.0 KiB will be freed.
    Continue? [y/n/?] (y): y                     
    Removing ushare-1.1a-3.1 [error]
    Removal of (31793)ushare-1.1a-3.1.i586(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: %preun(ushare-1.1a-3.1.i586) scriptlet failed, exit status 7
    
    
    Abort, retry, ignore? [a/r/i] (a): a
    Problem occured during or after installation or removal of packages:
    Installation aborted by user
    I've also tried doing an "rpm -e" but that didn't work either. Any suggestions?

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Package refuses to uninstall

    When trying this with rpm -e, what error message do you get - the same
    one?

    Jim



    --
    Jim Henderson
    openSUSE Forums Moderator

  3. #3
    Join Date
    Nov 2009
    Location
    Dallas, Texas, USA
    Posts
    55

    Default Re: Package refuses to uninstall

    Yup, unfortunately

    Code:
    rpm -e ushare-1.1a-3.1
    error: %preun(ushare-1.1a-3.1.i586) scriptlet failed, exit status 7

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,581

    Default Re: Package refuses to uninstall

    doubt it will work but did you try Yast?

    This appears to be a Redhat RPM??

  5. #5
    Join Date
    Nov 2009
    Location
    Dallas, Texas, USA
    Posts
    55

    Default Re: Package refuses to uninstall

    Quote Originally Posted by gogalthorp View Post
    doubt it will work but did you try Yast?

    This appears to be a Redhat RPM??
    Yeah, I tried it with the GUI too. It didn't work.

    I don't think it is. I got it from the OBS software search?

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Package refuses to uninstall

    On Wed, 16 Dec 2009 04:46:01 +0000, isaacj87 wrote:

    > gogalthorp;2088559 Wrote:
    >> doubt it will work but did you try Yast?
    >>
    >> This appears to be a Redhat RPM??

    >
    > Yeah, I tried it with the GUI too. It didn't work.
    >
    > I don't think it is. I got it from the OBS software search?


    You can try using rpm -e --force - that should allow it to uninstall even
    though the script is failing - but because the script is failing you
    might end up with some cruft left behind.

    Jim

    --
    Jim Henderson
    openSUSE Forums Moderator

  7. #7
    Join Date
    Nov 2009
    Location
    Dallas, Texas, USA
    Posts
    55

    Default Re: Package refuses to uninstall

    Quote Originally Posted by hendersj View Post
    On Wed, 16 Dec 2009 04:46:01 +0000, isaacj87 wrote:

    > gogalthorp;2088559 Wrote:
    >> doubt it will work but did you try Yast?
    >>
    >> This appears to be a Redhat RPM??

    >
    > Yeah, I tried it with the GUI too. It didn't work.
    >
    > I don't think it is. I got it from the OBS software search?


    You can try using rpm -e --force - that should allow it to uninstall even
    though the script is failing - but because the script is failing you
    might end up with some cruft left behind.

    Jim

    --
    Jim Henderson
    openSUSE Forums Moderator
    I tried that too. It gives me this message:

    Code:
    sudo rpm -e --force ushare-1.1a-3.1
    rpm: only installation, upgrading, rmsource and rmspec may be forced

  8. #8
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: Package refuses to uninstall

    On Wed, 16 Dec 2009 16:06:03 +0000, isaacj87 wrote:

    > Code:
    > --------------------
    > sudo rpm -e --force ushare-1.1a-3.1
    > rpm: only installation, upgrading, rmsource and rmspec may be forced
    >
    > --------------------


    Try:

    rpm -e --noscripts

    Should have the desired effect. I forgot that force couldn't be used
    there.

    Jim

    --
    Jim Henderson
    openSUSE Forums Moderator

  9. #9
    Join Date
    Nov 2009
    Location
    Dallas, Texas, USA
    Posts
    55

    Default Re: Package refuses to uninstall

    Quote Originally Posted by hendersj View Post
    On Wed, 16 Dec 2009 16:06:03 +0000, isaacj87 wrote:

    > Code:
    > --------------------
    > sudo rpm -e --force ushare-1.1a-3.1
    > rpm: only installation, upgrading, rmsource and rmspec may be forced
    >
    > --------------------


    Try:

    rpm -e --noscripts

    Should have the desired effect. I forgot that force couldn't be used
    there.

    Jim

    --
    Jim Henderson
    openSUSE Forums Moderator
    Perfect

    Thanks Jim!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •