Results 1 to 2 of 2

Thread: Slow X after kernel update to 2.6.27.39 [SOLVED]

  1. #1
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Slow X after kernel update to 2.6.27.39 [SOLVED]

    As the title says. System is openSUSE 11.1 running KDE3.5 with KDE4.3 also installed to use desktop effects in KDE3.5.

    After update X uses 90% CPU to scroll down a page in FF, OOo or even in text editor, either with KWin and KWin4. With KWin4 desktop effects can't be enabled in system config.

    From Xorg.conf:

    Code:
    Section "Device"
      BoardName    "ATI Radeon HD 3200 Graphics"
      Driver       "fglrx"
      Identifier   "Device[0]"
      Option       "XAANoOffscreenPixmaps" "true"
      Option       "Capabilities" "0x00000000"
      Option       "OpenGLOverlay" "off"
      Option       "FSAAScale" "0"
      Option       "FSAAEnable" "off"
      Option       "VideoOverlay" "on"
      Screen       0
      VendorName   "ATI"
    Rolling back to kernel 2.6.27.37 fixed the problem.

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Re: Slow X after kernel update to 2.6.27.39 [SOLVED]

    In another machine with NVidia graphics there is no problem with the updated kernel. It seems to be related to the ATI graphics/driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •