Results 1 to 8 of 8

Thread: Trouble installing Amaya IDE (W3C web utility)

  1. #1

    Default Trouble installing Amaya IDE (W3C web utility)

    I'm using OpenSuse 11.2 and I'm trying to install Amaya IDE. The thing is, it works perfect in 11.1, but now I'm getting this error:

    Subprocess failed. Error: RPM failed: error: Failed dependencies:

    libcrypto.so.7()(64bit) is needed by amaya_wx-11.3.1-0x86_64
    libssk.so.7()(64bit) is needed by amaya_wx-11.3.1-0x86_64

    Now considering that OpenSuse uses libcrypto.so.098()(64bit) & libssl.so.098()(64bit), what's the work around?

    Can anybody help on this one?

    ..and I've also tried installing from source with a bunch of errors I don't understand. (Sorry not a programmer)

  2. #2

    Default Re: Trouble installing Amaya IDE (W3C web utility)

    So I've answered my own question.

    The issue is Amaya 11.3 isn't compatible with OpenSuse 11.2 (haven't check it on 11.1)

    The libcrypto.so libssl.so aren't compatible to current libs

    The work around is to download Amaya 11.2. Amaya 11.3 was released December 9 2009. So maybe they'll fix the issue before too long.

  3. #3
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: Trouble installing Amaya IDE (W3C web utility)

    What are your experiences with Amaya? Last time I tried it, it was unusable.
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  4. #4
    javacrazed NNTP User

    Default Re: Trouble installing Amaya IDE (W3C web utility)

    amaya 11.2 is completely unusable ...horrible

  5. #5

    Default Re: Trouble installing Amaya IDE (W3C web utility)

    Workaround:
    1) install compat-openssl097g package
    2)
    Code:
    cd /usr/lib (or /usr/lib64 for x86-64)
    ln -s libssl.so.0.9.7 libssl.so.7
    ln -s libcrypto.so.0.9.7 libcrypto.so.7

  6. #6
    Join Date
    Oct 2009
    Location
    Berlin.
    Posts
    90

    Default Re: Trouble installing Amaya IDE (W3C web utility)

    The problem persists in OpenSuse 11.3

    Amaya doesn't work. It simply doesn't start.

    Is there is a solucion for this?

    Thanks.

  7. #7
    Join Date
    Apr 2010
    Location
    Rocksprings, TX
    Posts
    42

    Default Re: Trouble installing Amaya IDE (W3C web utility)

    Quote Originally Posted by mtelnov View Post
    Workaround:
    1) install compat-openssl097g package
    2)
    Code:
    cd /usr/lib (or /usr/lib64 for x86-64)
    ln -s libssl.so.0.9.7 libssl.so.7
    ln -s libcrypto.so.0.9.7 libcrypto.so.7
    Well, tried this. amaya still hangs when starting. I really would like to get this running since it has (at least the windows version) some neat features.
    SuSE 11.2 on a HP-dv7-3057nr with AMD Vision 2.2 GHZ 64bit processor. 4096 RAM and 500 Gb HDD.
    Server is an OLD Gateway e-3400 with SuSE 11.3 with a LAMP server.

  8. #8
    Join Date
    Oct 2011
    Location
    Nashville, GA
    Posts
    1

    Default Re: Trouble installing Amaya IDE (W3C web utility)

    Thanks to Mtelnov and Jim7634 I Got amaya_wx-11.3.1-0.i386.rpm to work on 11.4 Once i did what they said i installed it and had selected to break it and it works. thanks so much for your input.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •