Results 1 to 3 of 3

Thread: Gargoyle

  1. #1
    NewBox NNTP User

    Post Gargoyle

    Hey,
    I hope this is the right part of the forum for this:

    I recently installed openSuSE (32bit) on vBox and been having a blast. My problem now is that I cannot get 'gargoyle' the interactive fiction interpreter to work... I went to the correct page and downloaded the .deb package (tried getting the source code and using jam to compile, but I'm not tech-saavy enough to pull it off... so it never worked) and used alien (sudo alien -r <package>) to turn it from .deb to .rpm. Then I ran it through the install app and it worked fine...

    but now when I try running any files in it (gargoyle <filename>) I simply get an "error while loading shared libraries: libsmpeg-0.4.so.o:cannot open shared object file: no such file or directory"

    I tried installing some libraries that were mentioned in other posts, but to no avail.

    if I have understood correctly the issue is with the libraries needed to play sound... is there any way I can disable this feature and just get on with it?

    Hope some Gargoyle user here knows the answer,
    -NB

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Gargoyle

    It is looking for SDL MPEG library.
    Code:
    su
    zypper install smpeg
    openSUSE 12.3 (x86_64) with Kernel 3.7.10-1.16-desktop and KDE 4.11.2 on MacBook Pro
    Latest MS Windows version used: Win95

  3. #3

    Default Re: Gargoyle

    Hello NewBox,

    I'm not a Gargoly user, but I found out that the library libsmpeg-0.4.so.0 is available in the package libsmpeg-0_4-0.
    You can install it trough YaST if you haven't tried it already. I hope this works for you.

    Good luck.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •