Results 1 to 10 of 10

Thread: Abiword fails

  1. #1

    Default Abiword fails

    Installed Abiword plus some dependencies (on OS 11.2), now on opening a file I get the following errors:

    error: empty dic file
    Hash Manager Error : 2
    error: empty dic file
    Hash Manager Error : 2
    Aborted

    Following which Abiword exits.
    Any thoughts as to causes?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: Abiword fails

    Looks like you missed something. Dictionary files maybe??

  3. #3
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Abiword fails

    May be starting it from terminal will give more idea about the error.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  4. #4

    Default Re: Abiword fails

    Quote Originally Posted by gogalthorp View Post
    Looks like you missed something. Dictionary files maybe??
    No abiword is bugged, i open it up and try to open a doc... CRASH!

    Code:
    abiword
    error: empty dic file
    Hash Manager Error : 2
    error: empty dic file
    Hash Manager Error : 2
    Aborted
    Quote Originally Posted by mmarif4u View Post
    May be starting it from terminal will give more idea about the error.
    Yes i did that, and the OP seems to have done the same.
    https://features.opensuse.org/308357

  5. #5
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Abiword fails

    I had just installed it an hour ago, and its working fine here.
    Maybe its a bug or some dependency issue.

    Better to report it to bugzilla for further investigation.

    Bugzilla Main Page

    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  6. #6
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Abiword fails

    FWIW it is broken here too! If I open an Abi doc, it opens for a few seconds, crashes and saves a back-up copy!

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  7. #7

    Default Re: Abiword fails

    Quote Originally Posted by TaraIkeda View Post

    Yes i did that, and the OP seems to have done the same.
    Yes I did, amazing how on all forums people never seem to read the posts they're replying to!

  8. #8

    Default Re: Abiword fails

    As a work-round, this seems to clear the problem,

    Open Abiword with no file loaded;
    On the Edit -> Preferences -> Spell checking tab, deselect 'Check spelling as you type' (and maybe the grammar check too);
    Open a suitable .doc file (or other type, I didn't check);
    Run a manual spell check, the application should run this without closing;
    Recheck the boxes in Prefs -> Spell checking;
    Restest the app.

    Well that seemed to work for me!

    (Amazing how little testing these Linux apps get these days)

  9. #9
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Abiword fails

    I still have this issue, I have uninstalled and reinstalled, and tried Ruby's workaround, any hints anyone?

    I open Abiword, open a document (same with .abi, .txt and .rtf) it crashes, saving a backup copy.
    It does not seem to crash with in-line spell check "OFF", and the spell check works when invoked manually in this mode, so a dictionary IS available and works. However, checking the option for in-line spell check, and the fault re-occurs.....

    stephen@home:~> abiword --verbose=1

    (abiword:5576): libglade-WARNING **: Could not load support for `gnome': unknown dl-error

    (abiword:5576): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
    error: empty dic file
    Hash Manager Error : 2
    error: empty dic file
    Hash Manager Error : 2
    Aborted

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  10. #10
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Smile Re: Abiword fails

    As there was no traffic here, and the problem was still not resolved, I decided to uninstall Abiword....
    But when in Yast I tried cilcking update instead, although now newer versions were showing (this is not the first time I have done this).
    The problem seems now to have been solved.

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •