Results 1 to 8 of 8

Thread: Repository error

  1. #1
    Kevin Miller NNTP User

    Default Repository error

    When I start YaST, Software Management I get the following error:
    =====================================
    There was an error in the repository initialization.
    File './repo/repoindex.xml' not found on medium
    'http://en.opensuse.org/KDE/Repositories#KDE_4.3.x'

    History:
    - [AbstractCommand.cc:195]
    URI=http://en.opensuse.org/KDE/Repositories/repo/repoindex.xml
    =====================================

    Looking in repositories, I don't have that URL in the mix. My
    repositories are:
    mkm@koala:~> zypper lr -d
    # | Alias | Name |
    Enabled | Refresh | Priority | Type | URI
    | Service
    ---+-------------------------------------+-----------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
    1 | 11.2 | Videolan 11.2 |
    No | No | 150 | rpm-md |
    http://download.videolan.org/pub/vlc/SuSE/11.2/
    |
    2 | KDE_4.3 | KDE 4.3 |
    Yes | Yes | 99 | rpm-md |
    http://download.opensuse.org/reposit...openSUSE_11.2/
    |
    3 | Nvidia | Nvidia |
    Yes | Yes | 99 | rpm-md |
    ftp://download.nvidia.com/opensuse/11.2/
    |
    4 | Packman Repository | Packman Repository |
    Yes | Yes | 90 | rpm-md |
    http://ftp.skynet.be/pub/packman/suse/11.2/
    |
    5 | http-download.opensuse.org-b2b37260 | Updates for openSUSE 11.2-0 |
    Yes | Yes | 99 | rpm-md |
    http://download.opensuse.org/update/11.2/
    |
    6 | openSUSE 11.2-0 | openSUSE 11.2-0 |
    No | No | 99 | yast2 | cd:///
    |
    7 | repo-debug | openSUSE-11.2-Debug |
    No | Yes | 99 | yast2 |
    http://download.opensuse.org/debug/d...11.2/repo/oss/
    |
    8 | repo-non-oss | openSUSE-11.2-Non-Oss |
    Yes | Yes | 120 | yast2 |
    http://download.opensuse.org/distrib.../repo/non-oss/
    |
    9 | repo-oss | openSUSE-11.2-Oss |
    Yes | Yes | 120 | yast2 |
    http://download.opensuse.org/distrib...11.2/repo/oss/
    |
    10 | repo-source | openSUSE-11.2-Source |
    No | Yes | 99 | yast2 |
    http://download.opensuse.org/source/...11.2/repo/oss/
    |

    (sorry for the ugly line wrapping).
    Any clues/help appreciated.

    TIA...

    ....Kevin
    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

  2. #2

    Default Re: Repository error

    This the problem most of us that have behind a proxy.
    A recent update we did on the system might have introduce the problem.
    Search with keywork 'update' in the forum

  3. #3
    Kevin Miller NNTP User

    Default Re: Repository error

    arxidiamidia wrote:
    > This the problem most of us that have behind a proxy.
    > A recent update we did on the system might have introduce the problem.
    > Search with keywork 'update' in the forum
    >
    >

    Um, can you be a bit more specific? Looking for 'update' returned
    several hundred posts, unrelated to my problem. I tried to refine the
    search but still didn't have any luck w/that specific error. FWIW, I'm
    not behind a proxy.

    Thanks though...

    --
    Kevin Miller
    Juneau, Alaska
    http://www.alaska.net/~atftb
    In a recent poll, seven out of ten hard drives preferred Linux.

  4. #4

  5. #5
    Kevin Miller NNTP User

    Default Re: Repository error

    arxidiamidia wrote:
    > Some links for you:
    > 'zypper refresh problem - openSUSE Forums' (http://tinyurl.com/yc4ttr6)
    > 'YAST is unable to update - openSUSE Forums'
    > (http://tinyurl.com/ykrkfeh)
    > 'Still not able to update - openSUSE Forums'
    > (http://tinyurl.com/y9pwfce)


    Thanks. I'll check those out. Unfortunately, with the current version
    of Thunderbird (v3), whenever I go into newsgroups T-bird locks up.
    Don't know if anyone else is having that problem but that's a different
    thread.

    I'll have to print those out from work and take them home.

    A bit more info thouugh. I was confused by the error as it referenced
    'http://en.opensuse.org/KDE/Repositories#KDE_4.3.x' which doesn't appear
    anywhere in my repository list. Last night however, I was on the
    Software Repositories dialog in YaST and noticed the View option in the
    upper right. I changed it to 'All Services' rather than 'All
    Repositories' and there was the entry! I disabled it, and the error
    went away.

    Now however I'm wondering what the 'Services' are and how they differ
    from repositories. Also wonder where it came from, but suspect maybe
    one click. I clicked on Help, but it was rather vague. At least to me.
    On an 11.2 install here at work there are no services installed - just
    repositories.

    Appreciate any insights...

    ....Kevin
    --
    Kevin Miller
    Juneau, Alaska
    http://www.alaska.net/~atftb
    In a recent poll, seven out of ten hard drives preferred Linux.

  6. #6

    Default Re: Repository error

    Hi,

    I have installed openSuSE 11.2 on two different computer (one 64 bit, the other 32 bit), and I experienced the same issue on both computers I cannot reach any Software repositories behind our Proxy, if I take these computer at home without proxy it works fine. Is there any bug known?
    Internet download or surfing works over the proxy ( Firefox, wget or curl)

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,497
    Blog Entries
    15

    Default Re: Repository error

    Quote Originally Posted by panalpinacom
    Hi,

    I have installed openSuSE 11.2 on two different computer (one 64 bit,
    the other 32 bit), and I experienced the same issue on both computers I
    cannot reach any Software repositories behind our Proxy, if I take these
    computer at home without proxy it works fine. Is there any bug known?
    Internet download or surfing works over the proxy ( Firefox, wget or
    curl)
    Hi
    Try editing;
    Code:
    /etc/sysconfig/proxy
    You need to add;
    Code:
    HTTP_PROXY="http://USER:PASSWORD@proxy-url:PORT"
    <http://forums.opensuse.org/network-internet/430064-yast-repository-update-fails-when-using-proxy.html#post2098493>

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.39-0.3-default
    up 12:59, 2 users, load average: 0.05, 0.05, 0.08
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18


  8. #8

    Default Re: Repository error

    Hi,

    I already try that, it doesn't work!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •