Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Problems with Wine in openSuSE 11.1

  1. #1

    Angry Problems with Wine in openSuSE 11.1

    Hey guys,
    First time posting here. I'd like to explain a problem I've been battling since I went back to SuSE.

    I am using SuSE version 11.1 and app Wine version 1.1.34. The huge problem that I've been having is in trying to play World of Warcraft. I could never successfully install the game, and it got to the point where I had to use my friend's Windows drive to copy the directory over from his drive to mine. Whenever I would have to get a patch, there would be some kind of a:
    *download or install fail error
    *texture read/mapping error [can't read Kalimdor_31_21.adt]
    *Segmentation fault / client error 9

    I use wine via konsole so that i can get read out, and a lot of times I get a STUB! line which doesn't cause any issues but seems a little strange to me. I have tried so many things to handle these issues.
    *manually download/update patches
    *using the WoW included repair module
    *deleting the .wine directory and reinstalling
    *downgrading and upgrading to earlier and later versions
    *cause reset of folder ownership to fix previous issues by chown-ing several times

    I posted a bug about this in the winehq's bugzilla, but I am not getting any answers. Frankly, I'm getting wicked tired of wine misbehaving like this. I can't install KVM, and VMware refuses to work on my machine. I am NOT putting a windows drive into my computer case. Has anyone has problems like these, and if so, could give me some advice on what to do?

    Much appreciated, Thank you.

  2. #2

    Default Re: Problems with Wine in openSuSE 11.1

    Quote Originally Posted by Luukasama View Post
    I am NOT putting a windows drive into my computer case.
    now that needs some appreciation!

    now, could you try replacing

    /home/your_name/.wine/drive_c/Program Files/World of Warcraft/wtf/config.wtf
    with the one from here> http://echtor2oo3.de/Config.wtf

    did you start wine with the -opengl parameter?

  3. #3

    Exclamation Re: Problems with Wine in openSuSE 11.1

    Hello there,

    Yes, I always run WoW with the -opengl tag even though I read opengl is automatically used and you don't need that.

    ANYWAY, here are the news:

    I did copy over the config you gave me [made a copy of my old one, of course] and that actually made the patch install successfully! However, I got a brand new error:

    Runtime error
    Program: CProgram Files\World of Warcraft\Wow.exe [god, so awkward doing the backlash - **** Windows *shakes fist*]
    R6034
    An application has made an attempt to load the C runtime library incorrectly

    Now, since it did patch it, should I put back my old config into the .wtf file? I'm tempted to do that, but I wanted to hear your answer on that first. I'm just wondering if all this time the reason I was ever getting errors is because of the .wtf file, how do I fix that without having to use someone else's? OR is this what I just had to do to get that fixed once I get rid of that runtime error?

  4. #4

    Default Re: Problems with Wine in openSuSE 11.1

    Oh, totally forgot. Here is the tail end of what happened after I used konsole. Notice how there is a STUB line. Is that supposed to be like that? [I know I could've edited the other reply, but it didn't let me do it].

    fixme:wininet:InternetSetOptionW INTERNET_OPTION_SEND/RECEIVE_TIMEOUT 5000
    fixme:reg:GetNativeSystemInfo (0x37404484) using GetSystemInfo()
    fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_CONTEXT_VALUE; STUB
    fixme:actctxarse_assembly_elem wrong version for assembly manifest: 8.0.50727.762 / 8.0.50727.4053

    fixme:actctxarse_manifest_buffer failed to parse manifest L"C\Program Files\\World of Warcraft\\Microsoft.VC80.CRT.manifest"

    fixme:actctxarse_depend_manifests Could not find dependent assembly L"Microsoft.VC80.CRT" (8.0.50727.762)

    err:ntdll:RtlpWaitForCriticalSection section 0x7bcaa784 "loader.c: loader_section" wait timed out in thread 002c, blocked by 0009, retrying (60 sec)
    err:ntdll:RtlpWaitForCriticalSection section 0x7bcaa784 "loader.c: loader_section" wait timed out in thread 0026, blocked by 0009, retrying (60 sec)
    err:ntdll:RtlpWaitForCriticalSection section 0x7bcaa784 "loader.c: loader_section" wait timed out in thread 0021, blocked by 0009, retrying (60 sec)
    wine: Critical section 7bcaa784 wait failed at address 0x7bc35399 (thread 002c), starting debugger...
    Unhandled exception: wait failed on critical section 0x7bcaa784
    err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x7bc35399
    Process of pid=0008 has terminated
    No process loaded, cannot execute 'echo Modules:'
    Cannot get info on module while no process is loaded
    No process loaded, cannot execute 'echo Threads:'
    luuka@celestiel:~> process tid prio (all id:s are in hex)
    0000000e
    00000014 0
    00000010 0
    0000000f 0
    00000011
    00000017 0
    00000016 0
    00000013 0
    00000012 0
    00000018
    00000019 0
    You must be attached to a process to run this command.
    No process loaded, cannot execute 'detach'

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Problems with Wine in openSuSE 11.1

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Problems with Wine in openSuSE 11.1

    Okay, I'll check out winetricks, but I am not sure if that's going to help. I already have winetricks installed, so unless there is some trick to that, I might need to do something else.

    Thank you for the link though. I will take a look at that and see if there is anything in there I did not do or tweak. In the meantime, is it okay to replace the .wtf config back to mine and see what happens?

  7. #7

    Default Re: Problems with Wine in openSuSE 11.1

    Forgot to add: I do have winetricks, but I didn't know I had to do something with it beyond just downloading it. Getting some runtime files now. Will report on if that worked or not after it's done

  8. #8

    Default Re: Problems with Wine in openSuSE 11.1

    Quote Originally Posted by Luukasama View Post
    . In the meantime, is it okay to replace the .wtf config back to mine and see what happens?
    as far as i know, NO. got wow working a year ago with that config, so dont alter it.

    for your problems now, i suggest giving all the error messages to us or even better to a wow forum.

  9. #9

    Default Re: Problems with Wine in openSuSE 11.1

    Brian, what I meant to say was since your config allowed me to patch it, I was going to take your copy and back it up, and then just replace with mine. I was thinking that because your config is perfect on YOUR system, but since I use different hardware...you know?

    I don't see how I can attach files here, so I'm going to insert the konsole output here when I try to log in. Since this forum thinks I'm posting over 4 images at once when I put the konsole output here, I'm doing a double post. Please forgive that...I can't figure out how to navigate this place.

  10. #10

    Default Re: Problems with Wine in openSuSE 11.1

    Here are the images of the errors I get. Perhaps a visual will help?

    first is the visual errors I get


    second is the konsole output

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •