Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Pain: GDM from 11.0 on 11.2 - Is it possible?

  1. #1
    Join Date
    Sep 2008
    Location
    Porto Alegre, RS, Brazil
    Posts
    72

    Unhappy Pain: GDM from 11.0 on 11.2 - Is it possible?

    Hi all.

    I'm having a (predicted) hard time trying to install an "older opensuse version package program" on the "newest opensuse version".

    First of all, let me explain "why would someone wan to use an old gdm version in the newest openSuse".

    Our aim here is to make opensuse 11.2 multiterminals. Yes, it's possible to make such a thing using simply XOrg and kdm, BUT there I fall in the limitation of having just one terminal for each video card (or, for each PCI Adrress).

    We want to have a terminal for each video output available (two per video card or PCI Address in our case). That can't be done with only XOrg. For that to work, I also need something like Xephyr or XNest. Preferably Xephyr since it's still in development, and have some "new stuff" available.

    Unfortunatelly, I'm trying for some time already to open more than one independent Xephyr section for each video card with kdm, editing kdmrc file, and I'm beggining to think that it can't be done. This feeling is also reinforced by the following information (http://en.wikibooks.org/wiki/Talk:Mu...ation/Xephyr): "No analogue for flexible=false in kdmrc - impossible."

    That, of course, drives me back to gdm. What on one hand is great, since basically ALL tutorials using Xephyr uses solely gdm instead of kdm. Unfortunatelly, as the GDM manuals online also states (GNOME Display Manager Reference Manual), "GDM 2.20 and earlier supported the ability to manage multiple displays with separate graphics cards, such as used in terminal server environments, login in a window via a program like Xnest or Xephyr, the gdmsetup program, XML-based greeter themes, and the ability to run the XDMCP chooser from the login screen. These features are did not get added back during the 2.22 rewrite."

    So, here is my problem: I can't use XOrg solely, because it can't deal with independent displays for each video output, just for each PCI Address. So I have to use Xephyr. But it seems that I can't also use Xephyr with KDM, So I have to use GDM. Unfortunatelly, I also can't use GDM versions newer than 2.20, So I have to use the GDM that comes with openSuse 11.0. There is a version available for 11.1 from M4r3k repository, but no one still for version 11.2.

    I tried to install, via one click, the gdm from 11.0 on my 11.2. The installation was smoothly. When I changed from kdm to gdm, however, the restart fails with the following error message (taken from /var/log/messages file):

    Dec 8 15:47:47 windu gdm[2285]: GLib-CRITICAL: g_key_file_get_value: assertion `key_file != NULL' failed

    It appears several times.

    Anybody has a clue here? Be it how to avoid this error message, how to use Xephyr into kdmrc file, another desktop manager, whatever? Or do I have to step back, surrender and use openSuse 11.0?

    Thanks a lot in advance for any help!

  2. #2

    Default Re: Pain: GDM from 11.0 on 11.2 - Is it possible?

    Only a tuppence in case no one that knows can actually help.

    Did you try a rebuild of the source for 11.1? In quite a few cases this works fine and if not may lead you to the bits that are broken(Though this might be dependency hell).
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  3. #3
    Join Date
    Sep 2008
    Location
    Porto Alegre, RS, Brazil
    Posts
    72

    Talking Re: Pain: GDM from 11.0 on 11.2 - Is it possible?

    Ok, "tuppence" needed an online dictionary here.

    Back to the subject, no, I didn't try to rebuild it from source. How would I do that? Could you point me to a tutorial for that? I'm used to compile programs, but never something that would mess straight in the Desktop Manager...

    And you meant 11.0, didn't you?

  4. #4

    Default Re: Pain: GDM from 11.0 on 11.2 - Is it possible?

    There is a version available for 11.1 from M4r3k
    11.0 might work but the further back you go the more breakage potential. Being the login manager may make it easier.

    packages for 11.2??? - openSUSE Forums
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  5. #5
    Join Date
    Sep 2008
    Location
    Porto Alegre, RS, Brazil
    Posts
    72

    Default Re: Pain: GDM from 11.0 on 11.2 - Is it possible?

    Ok, I'll try both so. And thanks for the link!

    If that doesn't work or yield any error, I report back here.

    Thanks again!!

  6. #6

    Default Re: Pain: GDM from 11.0 on 11.2 - Is it possible?

    I wonder why there aren't more people complaining about the new GDM. It seems to me that any reasonable and respectful programer would have started a fork instead of rewriting everything from scratch. When you want to change everything, you just write a new program and give it another name. He might have thought he would reinvent the wheel (he did not). Instead he throught a bunch of features away that were widely needed by many users. This is absolutely unacceptable! (hope you guys forgive me this single minute of bad mood).

  7. #7
    Join Date
    Sep 2008
    Location
    Porto Alegre, RS, Brazil
    Posts
    72

    Default Re: Pain: GDM from 11.0 on 11.2 - Is it possible?

    Don't worry, I agree.

    I think it's a two-fold reason. On one hand, I think much people that use KDE based distributions doesn't care about GDM. And even the ones who deal with Gnome, doesn't pay attention for the KDM X GDM differences, specially on the login screen.

    The other reason is that the main Gnome and GDM based distribution nowadays is Ubuntu, which on its turn still support the gdm 2.20.

    Anyway, I'll try the rpm rebuild tomorrow probably. Too much extra work around here now.

  8. #8

    Default Re: Pain: GDM from 11.0 on 11.2 - Is it possible?

    Quote Originally Posted by johannesrs View Post
    Don't worry, I agree.

    The other reason is that the main Gnome and GDM based distribution nowadays is Ubuntu, which on its turn still support the gdm 2.20.
    Ubuntu Karmic now comes with gdm 2.28

  9. #9
    Join Date
    Sep 2008
    Location
    Porto Alegre, RS, Brazil
    Posts
    72

    Default Re: Pain: GDM from 11.0 on 11.2 - Is it possible?

    Quote Originally Posted by please_try_again View Post
    Ubuntu Karmic now comes with gdm 2.28
    Almost right. Their repositories have BOTH versions, 2.20 and 2.28.

    http://packages.ubuntu.com/search?ke...ic&section=all

    Unfortunately, on my opinion this time they have done it right. Ok, ONCE IN A LIFETIME they have to make something right.

  10. #10
    Join Date
    Sep 2008
    Location
    Porto Alegre, RS, Brazil
    Posts
    72

    Default Re: Pain: GDM from 11.0 on 11.2 - Is it possible?

    Hi all.

    It's me again. I'm having problems with the Sources Repositories. Basically, I can't find a way to list the contents of them.

    Does anybody here has any clue? When I try to remove and add the URL back, it complains about the lack of the "content.key" file in the url provided. And there isn't any file with this name on that directories anyway.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •