Results 1 to 4 of 4

Thread: Non OSE Virtualbox strange behaviour

  1. #1

    Default Non OSE Virtualbox strange behaviour

    I installed Virtualbox 3.1.0 (non OSE as I required the USB support) on my 11.2 box. I got the 11.2 rpm download from the virtualbox.org site and installed it through yast.

    I've had a terrible time trying to install oS11.2 into a VM. I set up a VM and then tried installing oS11.2. The install hung twice, then when it completed a reboot gave all sorts of errors and none of default repos were installed. Now every time I reboot the installation screen comes up saying that the install did not complete, would I like to complete it. I choose yes and then it goes straight to the login screen.

    I tried loading the 4 main repos in YAST and doing a full unconditional update but that hasn't cured the "incompleted install screen" coming up at every reboot. Also, reboots keep giving errors about apparmour and the ifup being killed; and 2 out of 3 hung at the desktop once logging in. I can't even get to the logs.

    The install medium is the same as I used for installing 11.2 on the host so it should be fine.

    Is there an issue with non OSE Virtualbox and 11.2?

    My host is an AMD 64 x2 5200+ processor with 2GB ram.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  2. #2
    maheuser NNTP User

    Default Re: Non OSE Virtualbox strange behaviour

    During the installation of openSUSE 11.2 as a virtual maschine, the ose-virtualbox packages will be automatically installed. These conflict with the non-ose host and VirtualBoxAdditions. If you are lucky and get the opensuse-vm to come up ok you can see in yast that some ose packets are installed. You can not uninstall them now or your system gets very annoyed.

    Workaround

    1) During installation of opensuse 11.2 as a virtual maschine, switch to the detailed View in the Software manager. Then search for "virtual". Mark the VirtualBox OSE packages as "taboo" -- to never be installed!

    2) !!! Skip updates during Installation !!! If you don't, the ose packages will get auto-installed during the update even though you marked them taboo in the previous step.

    3) When opensuse is up, search again for "virtual" in the yast software manager. Cancel the ose-updates if they appear already marked. And lock all of the Virtualbox-OSE packages.

    4) install VirtualboxAdditions (non-ose)

    I use openSUSE 11.2 and Gnome, VirtualBox 3.1.0 r55467

    Hope this helped

  3. #3
    maheuser NNTP User

    Default Re: Non OSE Virtualbox strange behaviour

    I use openSUSE 11.2 64-bit and Gnome, VirtualBox 3.1.0 r55467

  4. #4

    Default Re: Non OSE Virtualbox strange behaviour

    Thanks for the advice. I'll try again with a fresh VM install.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •