Results 1 to 5 of 5

Thread: Gnome/Multiscreen and flash

  1. #1

    Default Gnome/Multiscreen and flash

    I'm using a Multiscreen setup, one connected through hdmi, the other through dvi. Main monitor is running 1680x1050, secondary 1360x768

    I've installed the ati drivers, and from there enabled Xinerama.

    If I maximize a flash video, it maximizes on the secondary screen, and in the wrong resolution, making me unable to watch in full screen.

    If I disable Xinerama, and use the built in Multiscreen options in the ati drivers I have the same issues, except when I have them set up as two seperate monitors, unable to drag windows to each other.

    Tried disabling hardware acceleration in flash, didn't fix the problem.

    Using opensuse 11.2 x64
    Flash 10.0.32.18-3.2.1 (i586)
    nspluginwrapper 1.2.2-5.6.1 (x86_64)

    xorg.conf

    Code:
    Section "ServerLayout"
    	Identifier     "aticonfig Layout"
    	Screen      0  "aticonfig-Screen[0]-0" 1360 0
    	Screen         "amdcccle-Screen[1]-1" 0 282
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    EndSection
    
    Section "ServerFlags"
    	Option	    "Xinerama" "on"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Monitor"
    	Identifier   "0-DFP1"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    	Option	    "PreferredMode" "1680x1050"
    	Option	    "TargetRefresh" "60"
    	Option	    "Position" "0 0"
    	Option	    "Rotate" "normal"
    	Option	    "Disable" "false"
    EndSection
    
    Section "Monitor"
    	Identifier   "0-DFP2"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    	Option	    "PreferredMode" "1360x768"
    	Option	    "TargetRefresh" "60"
    	Option	    "Position" "0 0"
    	Option	    "Rotate" "normal"
    	Option	    "Disable" "false"
    EndSection
    
    Section "Device"
    
      #BusID       "PCI:1:0:0"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	Option	    "Monitor-DFP1" "0-DFP1"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Device"
    	Identifier  "amdcccle-Device[1]-1"
    	Driver      "fglrx"
    	Option	    "Monitor-DFP2" "0-DFP2"
    	BusID       "PCI:1:0:0"
    	Screen      1
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Virtual   3600 3600
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "amdcccle-Screen[1]-1"
    	Device     "amdcccle-Device[1]-1"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    Thanks.

  2. #2

    Default Re: Gnome/Multiscreen and flash

    Bump, onder KDE it behaves differently.

    Take for example this video "http://www.youtube.com/watch?v=-zvCUmeoHpw"

    When I maximize it, the player maximizes, but the video itself doesn't

  3. #3

    Default Re: Gnome/Multiscreen and flash

    Bump, any ideas welcome

  4. #4

    Default Re: Gnome/Multiscreen and flash

    Well its fine for me, though a little slow... but i am not on dual monitors.
    Dual monitor support in linux has always been iffy though.
    But the slowness in flash on my end might be related to your issue, could mean the flashplugin is bugged... again.
    https://features.opensuse.org/308357

  5. #5

    Default Re: Gnome/Multiscreen and flash

    That would be rather annoying, is there no alternative flash player application ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •