Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Desktop effects not working in KDE 4.3.1 w/ GeForce 9500 GT

  1. #11
    Join Date
    Dec 2009
    Location
    New Jersey
    Posts
    9

    Default Re: Desktop effects not working in KDE 4.3.1 w/ GeForce 9500

    The timestamp on that xorg corresponds to my having made some changes in Sax2 this AM, specically changing xinerama to cloned display and then disabling dualhead when that didn't help. Neither made a difference. Now I'm on the road with a lap running 10.2, so trying a restart after renaming /ect/x11/xorg.conf will have to wait 'til PM. Worst case: I get to learn or relearn how to get x started without a GUI.

  2. #12
    Join Date
    Dec 2009
    Location
    New Jersey
    Posts
    9

    Default Re: Desktop effects not working in KDE 4.3.1 w/ GeForce 9500

    Allright, I realized on the road I had a 64bit opensuse DVD with me, so I just made another partition and installed it on the lap I had with me. I did not install any nvidia drivers. No xorg.conf file. Desktop effects worked fine, within the limits of the low end and old GPU. I start SaX2, just to make changes to save, save them and get an xorg.conf file and desktop effects don't work. Rename xorg.conf, restart, and all is well again. I think I'm fixed, but get home and on the machine in question, rename xorg.conf and restart. No desktop effects, but I get a message that another app has disabled compositing. Under the general tab of configure desktop settings, at the top, I now has a message that says compositing is not possible on this system as I lack X modules "composite" and "Damage". And I have no more dualhead. When I try to configure NVidia server setting, it wants to save the changes to xorg.conf, which of course is no longer there. I've restored the xorg.cong files and got my dual head going again. I'm not sure what the problem is at all. After I post this I'm going to remove the nvidia drivers and see what things look like.

  3. #13

    Default Re: Desktop effects not working in KDE 4.3.1 w/ GeForce 9500

    I have heard with certain nvidia cards that Kwin compositing is not so good.
    If you have a working system though its possible to live without the desktop effects though it does make things a little less attractive.
    You could however install Gnome, and use Compiz for effects.
    I only suggest installing gnome as with the more recent versions of KDE compiz does not like to co operate.
    https://features.opensuse.org/308357

  4. #14
    Join Date
    Dec 2009
    Location
    New Jersey
    Posts
    9

    Default Solved: Desktop effects not working in KDE 4.3.1 w/ GeForce

    Removing the Nvidia drivers did not go so well, and as fixing things from init3 would take me all weekend, I did a clean install.
    Immediately after install I had an xorg file, and no desktop effects. Renamed xorg.conf and desktop effects worked. Installed nvidia drivers the brainless way and still had desktop effects. Couldn't set up dualhead by configuring Nvidia server as it had no xorg.conf to write to, so I ran SaX2 and set it up from there (with xinerama); it of course made a new xorg.conf and both dualhead in xinerama mode and desktop effects worked.

    Oddly, with the previous install that had been problematic, two desktop effects, "magic lantern minimize" and "wobbly windows", had not only worked but had worked all through the process even regardless of whether they were were checkboxed or even whether desktop effects was enabled. In fact, they worked rather more dramatically than they do now. Having not yet gotten desktop effects to work properly, I didn't understand this at the time.

    I've saved all the xorg.conf files and will compare them later.

  5. #15
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: Desktop effects not working in KDE 4.3.1 w/ GeForce 9500

    I've lost track now of what you've done and what works and what doesn't but here are some general observations from my experience with NVIDIA, desktop effects, and dual monitors that might help:

    1. Ignore Sax2. Only use "nvidia-settings" as root to write xorg.conf. Never use the two together to write to the same xorg.conf.

    2. Xinerama and compositing don't mix. Xinerama disables compositing.
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •