Results 1 to 9 of 9

Thread: missing xorg.conf?

  1. #1

    Default missing xorg.conf?

    I cannot save my "Configure Desktop" settings. I have 2 monitors and a Nvidia 8500. All was well under 11.1 but neither an upgrade or fresh install will save my settings.

    Under configure desktop, I go to display and at first it shows both monitors overlapped and my screens are mirrored. I can tell it to position the second monitor to the right of the 1st, and apply and it will work until I reboot. I've tried it as root and as my end user. Also, I can't locate a xorg.conf. I have /etc/X11/xorg.conf.install, only.

    I thought the right nvidia drivers were installed automatically in version 11.2.

    AND, if I try to enable desktop settings, when I hit apply I get: Failed to activate desktop effects using the given configuration options. Settigns will be reverted to their previous values. I'm not even changing anything. Just enabling and hitting apply.

    Whiskey, Tango, Foxtrot?

  2. #2
    Join Date
    Dec 2008
    Location
    GMT-7
    Posts
    382

    Default Re: missing xorg.conf?

    I was a little taken aback by the missing xorg.conf file myself on a fresh 11.2 install, but that is apparently a perfectly valid situation. Only after I installed the ATI proprietary driver (I have ATI, not Nvidia) the "aticonfig --initial" command created the first ever xorg.conf on that machine.

    If you're not scared of a little adversity, I would try to install the proprietary nv driver instead. But be aware: for ATI fglrx cards on 11.2 that is a true adventure not for the faint of heart.
    Desk: AMD Phenom II X4 945 8GB RAM Radeon HD 3300 Arch Linux Xfce 4.8
    Lap: Intel 2.13GHz Core i3 M330 8GB RAM nVidia GeForce 310M Arch Linux KDE 4.7.3

  3. #3
    Join Date
    Sep 2008
    Location
    St Louis, MO USA
    Posts
    398

    Default Re: missing xorg.conf?

    Log out of the desktop, switch to a virtual terminal ('CTRL-ALT-F1'), log in as root, and run "telinit 3". Once that finishes, run "Xorg -configure" to generate an Xorg.conf. Now you can edit that as you wish, as well as see exactly what configuration Xorg is detecting (this new xorg.conf should be the same config Xorg is automatically using).

    Also, if you have a working Xorg.conf from another distro that is set up the way you like, you could just drop that in /etc/X11/. That ususally does the trick (no need to generate a new conf).

    As far as the Nvidia drivers, if they are installed automatically in 11.2, it's news to me. I don;t use Nvidiam but check this link from the wiki. It's been updated for 11.2, and there's a troubleshooting guide as well if something goes awry.
    Dell Inspiron 530 - C2Q@2.4Ghz; 6GB RAM; openSUSE 11.2 x86_64; KDE 4.4.1
    Dell Inspiron 1440 - C2D@2.2Ghz; 4GB RAM; openSUSE 11.2 x86; KDE 4.4.1
    Dell Latitude D531 - AMD Turion X2 64@2.0Ghz; 2GB RAM; Linux Mint 8

  4. #4
    palladium NNTP User

    Default Re: missing xorg.conf?

    badamsios wrote:
    > I thought the right nvidia drivers were installed automatically in
    > version 11.2.


    nope, *open*SUSE installs no proprietary software (like Nvidia's
    drivers) by default..

    > Whiskey, Tango, Foxtrot?


    install the driver and you troubles will be history...maybe..

    see: http://en.opensuse.org/Nvidia and do not use the "easy way"!

    it is only easy until a new kernel is installed and your screen goes
    black..

    recommended: http://en.opensuse.org/NVIDIA/The_hard_way

    it is the easiest way, in the long run..

    --
    palladium

  5. #5
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: missing xorg.conf?

    The proprietary NVIDIA drivers are not installed by default. Once you have installed them (follow Wiki instructions) you run "sudo nvidia-settings" and the proper xorg.conf will be written. Hopefully that'll be the end of your problems!
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: missing xorg.conf?

    Yeap the Nvidia drivers aren't installed automaticly in yast configure repositories and enable the nvidia repo, after installing the nvidia drivers you'll get a xorg.conf file, and sax2 is still here if U need an xorg file why not just run sax2 (in runlevel 3) and configure your gf cars( if U need vesa or nv drivers)

  7. #7
    Join Date
    Jul 2008
    Location
    Nottingham, UK
    Posts
    37

    Default Re: missing xorg.conf?

    I'm not sure that the above advice is entirely accurate any more. If you use the recommended ("Easy") way of installing the nvidia driver on 11.2, i.e. by using the nvidia repository, then once the driver has downloaded and installed through YAST Software Manager, all you need to do is log out of your session, log back in again, and all should be fine. You don't even need to fully reboot (suck on that, Windows!).

    You don't need to mess around with Sax2 (which is being depreciated any way - notice how you can't even see it in YAST any more), and no xorg.conf is created.

    Hopefully, you should be able to configure your monitors using your desktop session manager (you don't mention if you are using KDE or Gnome), or use the NVIDIA driver manager.

    If you do find you need an xorg.conf file, then one can be created by invoking Sax2.

  8. #8

    Default Re: missing xorg.conf?

    Well, before coming back to this forum, I did update my nvidia drivers like I had in 11.1, by adding the repository. Using KDE, I now see NO 2nd monitor in the Configure Desktop app. I can go to Applications/System/Configuration/Configure Nvidia Server Settings and select the options I want, tell it to save to the xorg.conf and it "appears" to be successful, but when I look at the .conf file I see this:

    Section "Screen"
    Identifier "Screen1"
    Device "Device1"
    Monitor "Monitor1"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "CRT-0: nvidia-auto-select +0+0"

    Section "Screen"
    Identifier "Screen1"
    Device "Device1"
    Monitor "Monitor1"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "CRT-1: nvidia-auto-select +0+0"

    My right screen is black, and I can move the mouse to that screen, but the mouse turns to an "X," and I cannot drag an app there. Of course what I want is one big monitor.

  9. #9

    Default Re: missing xorg.conf?

    Fortunately the primary use of OpenSuse at the moment is as a Vmware server and a Citrix client, so all I have to install are 1 server and 1 app. I installed 11.1, installed the Nvidia drivers and configured the monitors. Saved the xorg.conf to a USB drive and did a fresh install of 11.2. Installed the Nvidia drivers, ran the Nvidia config and created an xorg.conf file and then promptly over-wrote it with the one from 11.1 and all is well in my world again.

    Thanks MUCH all...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •