Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Virtual Desktop Shortcuts Not Working

  1. #1
    theox05 NNTP User

    Default Virtual Desktop Shortcuts Not Working

    Got SUSE installed (11.2) but for some reason my virtual desktop shortcuts aren't working. I have my drivers installed (Nvidia 8200M G) and the system sees and is using the device. Compositing is active, but Ctrl-Alt-Arrow Keys and my TAB combos do not work at all.

    I installed Compix thinking that was it, but still no dice.

    Any thoughts would be appreciated.

  2. #2
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: Virtual Desktop Shortcuts Not Working

    Not sure what you mean by "virtual desktop shortcuts". Does the virtual desktop pager on the panel work when you click on it? Or are you just looking for keyboard shortcuts so you can switch virtual desktops without the mouse? You say you installed Compiz so is that with Gnome, or did you install Compiz in KDE and disable Kwin?
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  3. #3
    theox05 NNTP User

    Default Re: Virtual Desktop Shortcuts Not Working

    The little snapshot/pager is present in the taskbar and I can switch by clicking with the mouse. I'm a newbie, not sure what Kwin is.Don't think I disabled it, but who knows! I'm running KDE.

    Just the Ctrl-Alt-Arrow key and TAB stuff isnt working. They just wont swap.

  4. #4
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: Virtual Desktop Shortcuts Not Working

    OK, so what did you use before you installed openSUSE? And what do you want those keyboard shortcuts to do? And why did you install Compiz? A combination of the answers to these questions will, I suspect, solve your puzzle.
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  5. #5
    theox05 NNTP User

    Default Re: Virtual Desktop Shortcuts Not Working

    I used Ubuntu 9.08 I think and I used the Ctrl-Alt-Arrow keys to switch desktops (right to move right, down to move down, etc). I installed compiz thinking this was my problem (didn't work before install either).

  6. #6
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Virtual Desktop Shortcuts Not Working

    Hi,

    I believe Ubuntu uses compiz, so that would be the reason why your ctrl+alt+arrow key doesn't work. In KDE to do this, click on the application launcher then choose Configure Desktop (Personal Settings). Under the category Computer Administration click Keyboard and Mouse. Click Global Keyboard Settings and then click the drop down menu next to KDE component and choose Kwin. Scroll down until you find Switch One Desktop to the Left and Switch One Desktop to the Right. Set the controls for those.

    You'll also have to set the control for Switch One Desktop Down and/or Switch One Desktop Up. This will let you use all four desktops (otherwise just left and right only let you go between desktops 1 and 2).

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  7. #7
    theox05 NNTP User

    Default Re: Virtual Desktop Shortcuts Not Working

    Ian, you are awesome, problem solved.

  8. #8
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Virtual Desktop Shortcuts Not Working

    No problem,

    Thank gminnerup for the process of elimination. I only knew what your situation was through the questions you answered.

    Also, if you find Kwin does not meet your needs you can try my how-to on how to install and configure compiz here:

    Installing and Configuring Compiz - openSUSE Forums

    If you have anymore questions just post them on the forums

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  9. #9
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,020

    Default Re: Virtual Desktop Shortcuts Not Working

    Quote Originally Posted by ijbreakey View Post
    No problem,

    Thank gminnerup for the process of elimination. I only knew what your situation was through the questions you answered.
    Well to be honest (as a former Gnome user) I knew all along what his problem was... Just wanted to teach him to ask the right questions for others to be able to help him (which you then did), or alternatively to figure it out for himself, something like this: that keyboard shortcut did this in Ubuntu. It was defined in Compiz. I don't need Compiz in KDE because of something called Kwin. Maybe KDE has its own way to define shortcuts?
    Günter

    Desk: Leap 42.2, KDE 5, Intel i3, 8Gb, Kingston 64Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  10. #10

    Default Re: Virtual Desktop Shortcuts Not Working

    I've got a similar problem. All global shortcuts for KWin have stopped working ─ no matter if they're the default ones, or ones defined by me. All the window/desktop switching, compositing disabling shortcuts, hell, even alt+f4 have stopped responding. Other shortcuts, global or normal, are workingp perfectly fine. I'm running KDE 4.3.4 from the 11.2 Factory repo.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •