Page 4 of 4 FirstFirst ... 234
Results 31 to 34 of 34

Thread: no Cli for php 5.3.x on SUSE 11.2 ?!

  1. #31

    Default Re: no Cli for php 5.3.x on SUSE 11.2 ?!

    Quote Originally Posted by ken_yap View Post
    Past performance is no indication of future results, as they say when you buy stocks.

    If Karmic went to PHP 5.3 that would explain why ncurses is missing from it.

    Edit: Well no, Karmic stayed at 5.2.10. I'll leave it to Chrysantine to explain why no coloring in Karmic. But the fact is that openSUSE 11.2 has no php5-ncurses and you have to build your own.
    ok lol .

    when I try to install php-ncurses with pecl ( I've checked pecl installation with your link and it think that is correctly installed on my machine ) I got the same error

    Code:
    ...
     cc -I. -I/tmp/pear/download/ncurses-1.0.0 -DPHP_ATOM_INC -I/var/tmp/pear-build-hichem/ncurses-1.0.0/include -I/var/tmp/pear-build-hichem/ncurses-1.0.0/main -I/tmp/pear/download/ncurses-1.0.0 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -I/usr/include/ncurses -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/download/ncurses-1.0.0/ncurses_fe.c  -fPIC -DPIC -o .libs/ncurses_fe.o
    /tmp/pear/download/ncurses-1.0.0/ncurses_fe.c:29: error: duplicate 'static'
    /tmp/pear/download/ncurses-1.0.0/ncurses_fe.c:35: error: duplicate 'static'
    /tmp/pear/download/ncurses-1.0.0/ncurses_fe.c:42: error: duplicate 'static'
    /tmp/pear/download/ncurses-1.0.0/ncurses_fe.c:169: error: 'first_arg_force_ref' undeclared here (not in a function)
    /tmp/pear/download/ncurses-1.0.0/ncurses_fe.c:183: error: 'second_arg_force_ref' undeclared here (not in a function)
    make: *** [ncurses_fe.lo] Error 1
    ERROR: `make' failed

  2. #32
    Jon_Freeman NNTP User

    Default Re: no Cli for php 5.3.x on SUSE 11.2 ?!

    Quote Originally Posted by halfkiller View Post
    /home/hichem/Desktop/ncurses-1.0.0/ncurses-1.0.0/ncurses_fe.c:42: error: duplicate 'static'
    /home/hichem/Desktop/ncurses-1.0.0/ncurses-1.0.0/ncurses_fe.c:169: error: 'first_arg_force_ref' undeclared here (not in a function)
    /home/hichem/Desktop/ncurses-1.0.0/ncurses-1.0.0/ncurses_fe.c:183: error: 'second_arg_force_ref' undeclared here (not in a function)
    make: *** [ncurses_fe.lo] Error 1
    [/CODE]have you any idea ?
    I've found a couple of pages like this one PECL :: Bug #14369 :: Build/Register issue with PHP 5.3.0

    but tbh to resolve it, I'd be asking others to help me.

  3. #33
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: no Cli for php 5.3.x on SUSE 11.2 ?!

    Quote Originally Posted by halfkiller View Post
    I've worked with Ubuntu from 8.04 and I always have color on php command line . Perhaps your VM don't support some packages that are needed to colorize php command line...
    Just a moment ago you said php-cli was the package that provided colours, now suddenly it's no longer so - getting a little tangled in your reasoning here?

    Or perhaps you just have absolutely no clue as to what you're talking about? Seriously.

    Quote Originally Posted by halfkiller View Post
    To be honest, I think that is better to don't use a virtual machine for a professional work
    Yes because the largest companies in the world are just running virtual machines for fun, not for professional work. *rolleyes*

  4. #34

    Default Re: no Cli for php 5.3.x on SUSE 11.2 ?!

    I know this topic is pretty old. But it's still

    1. was on top of search result page
    2. has no answer
    3. my 13.2 has no colored output for symfony console out of the box

    so, answer is

    Code:
    sudo zypper in php5-posix

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •