Results 1 to 7 of 7

Thread: Maybe a Kwrite bug ?

  1. #1
    Join Date
    Jun 2008
    Location
    Halifax, Nova Scotia
    Posts
    29

    Default Maybe a Kwrite bug ?

    Anyone else using openSuse 11.2 find that you can't launch Kwrite as su from a terminal?

    I can launch it as a regular user and I can log in as root and launch it but no way can I get it to launch as su.

    Cheers,
    Carlton

  2. #2
    palladium NNTP User

    Default Re: Maybe a Kwrite bug ?

    in opensuse you must use kdesu, like so:

    kdesu kwrite

    then it will launch...i forgot why, but it has been that way for a
    while (maybe since 11.0 or or or)

    ps, in gnome it is (guess!) gnomesu

    --
    palladium

  3. #3
    Join Date
    Jul 2008
    Location
    Netherlands
    Posts
    1,140

    Default Re: Maybe a Kwrite bug ?

    Note that this goes for pretty much any application with a GUI and I think it had to do with starting in the roots environment otherwise.. which isn't quite fully loaded .
    Special effects <- KDE 4.2 Showing off
    More KDE -> PINK KDE

  4. #4
    graham NNTP User

    Default Re: Maybe a Kwrite bug ?

    csm58 wrote:

    >
    > Anyone else using openSuse 11.2 find that you can't launch Kwrite as su
    > from a terminal?
    >
    > I can launch it as a regular user and I can log in as root and launch
    > it but no way can I get it to launch as su.
    >
    > Cheers,
    > Carlton
    >
    >

    You can use su -m to give root permissions.
    But as the user environment is preserved there will be error messages.
    Normally kdesu woould be used.

  5. #5
    Join Date
    Jun 2008
    Location
    Halifax, Nova Scotia
    Posts
    29

    Default Re: Maybe a Kwrite bug ?

    Thanks very much. kdesu worked like a charm.

    Is it fairly recent (6months 1 year) that kde had to go in front of su?

  6. #6
    palladium NNTP User

    Default Re: Maybe a Kwrite bug ?

    > Is it fairly recent (6months 1 year) that kde had to go in front of
    > su?


    i think it is a "SUSE thing" not a KDE thing...and it either began
    with 11.0 or 11.1, i really don't remember which...but is hasn't been
    much over a year, if that long...iirc

    --
    palladium

  7. #7
    Jon_Freeman NNTP User

    Default Re: Maybe a Kwrite bug ?

    Quote Originally Posted by palladium View Post
    i think it is a "SUSE thing" not a KDE thing...and it either began
    with 11.0 or 11.1, i really don't remember which...but is hasn't been
    much over a year, if that long...iirc
    I think it depends on what you've been using. su/kwrite will work using KDE3 on 11.1. Had (as mentioned on another thread today) noticed differences before but now I want 11.2 have only just been "forced" into different ways.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •