Results 1 to 5 of 5

Thread: KNetworkManager does not autostart anymore...

  1. #1
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Unhappy KNetworkManager does not autostart anymore...

    Since a few days KNetworkManager does not show up in the system tray anymore - nor is it running.

    It used to start automatically after logon, after it was started manually once.

    Now, after switching the "Network Setup Method" (with YaST>Network Settings) from "User controlled with NetworkManger" to "Traditional Method with ifup" and back a number of times, the KNetworkManager does not want to restart automatically any more...

    Any idea what my cause this problem?


    BTW: I am on openSuse 11.1 with kernel 2.6.27.39-0.2-pae
    Last edited by hardy59; 06-Dec-2009 at 06:30. Reason: fixing typos

  2. #2
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Default How does KNetworkManager start automatically?

    Looks like my problem is a singular case, so let me rephrase my question:

    How does KNetworkManager - and all the other system tray programs - start automatically after logon to KDE?

    Adding KNetworkManager to the autostart list in the "Personal Settings" does the job, but this seems not to be the official/regular way to accomplish such autostarts...

    Any hints are appreciated very much.

  3. #3
    Join Date
    Mar 2009
    Location
    London
    Posts
    426

    Default Re: KNetworkManager does not autostart anymore...

    Hi,

    You could check that ~/.kde/share/config/knetworkmanagerrc has Autostart=yes.


    Regards,
    Barry.
    Desktop: openSUSE 11.3 (x86) LXDE
    Laptop: Arch Linux (x86_64) GNOME 3

  4. #4
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Thumbs up Re: KNetworkManager does not autostart anymore...

    @Barry_Nichols

    Autostart is set to "no"....
    Setting it back to "yes" did the trick!
    Thank you very much!

    Cheers,
    Hardy

  5. #5
    Join Date
    Mar 2009
    Location
    London
    Posts
    426

    Default Re: KNetworkManager does not autostart anymore...

    Hi,

    You're welcome.
    Glad you got it working.


    Regards,
    Barry.
    Desktop: openSUSE 11.3 (x86) LXDE
    Laptop: Arch Linux (x86_64) GNOME 3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •