Installing SuSE 11.2. Ran KGpg the first time, all went well. But I wanted to use my existing keys, not new ones, so I nuked the newly created pubring.gpg, secring.gpg, trustdb.gpg and symlinked the older ones into /home/andy/.gnupg.

Now when I run KGpg as user andy the icon bounces up and down, but nothing happens. Doing ps -A|grep gpg shows the process, but nothing exists on the screen.

I've tried nuking, reinstalling etc, with a reboot after each nuke, no change.

I ran it as root, it runs correctly. So there is a permissions problem somewhere:
+ /usr/share/applications/kde4/kgpg.desktop is rw-r--r-- root but so are all the other .desktops.

+ The desktop calls the appplication with kgpg %U, which implies there is a .conf or rc file somewhere setting the users.

+ I located /usr/share/kde4/apps/kgpg/kgpg.rc, but it doesn't mention users or permissions.

+ I located /usr/bin/kgpgconf] but it is a binary.

+ I located /usr/share/kde4/config.kcfg/kgpg.kcfg, no mention of users.

But I removed all three, upgraded kGpg and tried again. No change.

I then commented out cross-correlation in /home/andy/.gnupg/gpg.conf and tried again. No change.

I've tried all of the following without success:
+ Nuke \home\andy .gnupg and try again
+ Nuke \home\andy .gnupg, copy the /root/.gnupg over, reset owner and permissions to andy:users 0755 and try again

I guess I can run it as root, but I'd really rather fix this. Of course I know that I'll figure it out as soon as I postthis but... :-(

Thanks in advance,
Andy Lavarre
alavarre(with the email address)